Disable -Werror=nonnull on getcwd(0, 4096) because GCC incorrectly warns that
the second argument should be NULL with recent glibc. See:
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=96832
https://sourceware.org/bugzilla/show_bug.cgi?id=26545
diff --git a/nss/coreconf/nsinstall/nsinstall.c b/nss/coreconf/nsinstall/nsinstall.c
--- a/nss/coreconf/nsinstall/nsinstall.c
+++ b/nss/coreconf/nsinstall/nsinstall.c
@@ -236,14 +236,20 @@ main(int argc, char **argv)
return 0;
if (!cwd) {
+#pragma GCC diagnostic push
+#pragma GCC diagnostic ignored "-Wnonnull"
cwd = GETCWD(0, PATH_MAX);
+#pragma GCC diagnostic pop
if (!cwd)
fail("could not get CWD");
}
/* make sure we can get into todir. */
xchdir(todir);
+#pragma GCC diagnostic push
+#pragma GCC diagnostic ignored "-Wnonnull"
todir = GETCWD(0, PATH_MAX);
+#pragma GCC diagnostic pop
if (!todir)
fail("could not get CWD in todir");
tdlen = strlen(todir);
/td>
Age | Commit message (Expand) | Author |
2022-07-12 | guix: Really export 'define-public'....This is a followup to 3858275962f1ac567b5dce2355035f9eddea0a05, which
didn't have any effect.
* guix.scm: Explicitly use (guix packages) so #:re-export-and-replace
is effective.
| Ludovic Courtès |
2021-09-14 | guix: Replace 'define-public'....This is a followup to 8531997d2a1e10d574a6e9ab70bc86ade6af4733.
* guix.scm: Use #:re-export-and-replace for 'define-public'.
| Ludovic Courtès |
2021-06-29 | (guix) no longer pulls in (guix ftp-client)....That choice was made in 2014 and never made much sense.
* guix.scm (%public-modules): Remove 'ftp-client'.
| Ludovic Courtès |