Disable -Werror=nonnull on getcwd(0, 4096) because GCC incorrectly warns that the second argument should be NULL with recent glibc. See: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=96832 https://sourceware.org/bugzilla/show_bug.cgi?id=26545 diff --git a/nss/coreconf/nsinstall/nsinstall.c b/nss/coreconf/nsinstall/nsinstall.c --- a/nss/coreconf/nsinstall/nsinstall.c +++ b/nss/coreconf/nsinstall/nsinstall.c @@ -236,14 +236,20 @@ main(int argc, char **argv) return 0; if (!cwd) { +#pragma GCC diagnostic push +#pragma GCC diagnostic ignored "-Wnonnull" cwd = GETCWD(0, PATH_MAX); +#pragma GCC diagnostic pop if (!cwd) fail("could not get CWD"); } /* make sure we can get into todir. */ xchdir(todir); +#pragma GCC diagnostic push +#pragma GCC diagnostic ignored "-Wnonnull" todir = GETCWD(0, PATH_MAX); +#pragma GCC diagnostic pop if (!todir) fail("could not get CWD in todir"); tdlen = strlen(todir); /form> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cluster.scm
AgeCommit message (Collapse)Author
2021-05-28gnu: libraft: Update to 0.10.1Dion Mendel
* gnu/packages/cluster.scm (libraft): Update to 0.10.1 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
2020-11-30gnu: drbd-utils: Update to 9.15.1.Tobias Geerinckx-Rice
* gnu/packages/cluster.scm (drbd-utils): Update to 9.15.1.
2020-10-10gnu: drbd-utils: Update to 9.15.0.Marius Bakke
* gnu/packages/cluster.scm (drbd-utils): Update to 9.15.0.
2020-07-02gnu: Add drbd-utils.Marius Bakke
* gnu/packages/cluster.scm (drbd-utils): New variable.