Disable -Werror=nonnull on getcwd(0, 4096) because GCC incorrectly warns that
the second argument should be NULL with recent glibc. See:
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=96832
https://sourceware.org/bugzilla/show_bug.cgi?id=26545
diff --git a/nss/coreconf/nsinstall/nsinstall.c b/nss/coreconf/nsinstall/nsinstall.c
--- a/nss/coreconf/nsinstall/nsinstall.c
+++ b/nss/coreconf/nsinstall/nsinstall.c
@@ -236,14 +236,20 @@ main(int argc, char **argv)
return 0;
if (!cwd) {
+#pragma GCC diagnostic push
+#pragma GCC diagnostic ignored "-Wnonnull"
cwd = GETCWD(0, PATH_MAX);
+#pragma GCC diagnostic pop
if (!cwd)
fail("could not get CWD");
}
/* make sure we can get into todir. */
xchdir(todir);
+#pragma GCC diagnostic push
+#pragma GCC diagnostic ignored "-Wnonnull"
todir = GETCWD(0, PATH_MAX);
+#pragma GCC diagnostic pop
if (!todir)
fail("could not get CWD in todir");
tdlen = strlen(todir);
zed Guix
|
Age | Commit message (Expand) | Author |
2023-11-25 | gnu: odt2txt: Fix cross-compilation....* gnu/packages/textutils.scm (odt2txt): Fix cross-compilation.
[arguments]: Use Gexp and CC-FOR-TARGET.
Change-Id: I0a81e601813da0e4b2accaf835e3ea774b742df8
Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
| Zheng Junjie |
2023-11-25 | gnu: nkf: Fix cross-compilation....* gnu/packages/textutils.scm (nkf): Fix cross-compilation.
[arguments]: Use gexp and CC-FOR-TARGET.
Change-Id: Idd2cbdd89d4ce2feb484a6005e06f1eba491feea
Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
| Zheng Junjie |
2023-10-22 | gnu: go-github-com-stretchr-testify: Move to (gnu packages golang-check)....* gnu/packages/golang.scm (go-github-com-stretchr-testify): Move from
here...
* gnu/packages/golang-check.scm: ...to here.
* gnu/packages/databases.scm: Add (gnu packages golang-check) module.
* gnu/packages/education.scm: As above...
* gnu/packages/ipfs.scm: As above...
* gnu/packages/irc.scm: As above...
* gnu/packages/mail.scm: As above...
* gnu/packages/textutils.scm: As above...
* gnu/packages/version-control.scm: As above...
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
| Sharlatan Hellseher |
2023-09-30 | gnu: utfcpp: Update to 3.2.5....* gnu/packages/textutils.scm (utfcpp): Update to 3.2.5.
Signed-off-by: Christopher Baines <mail@cbaines.net>
| Hilton Chain |
2023-09-25 | gnu: dos2unix: Update to 7.5.1....* gnu/packages/textutils.scm (dos2unix): Update to 7.5.1.
Signed-off-by: Christopher Baines <mail@cbaines.net>
| Timotej Lazar |
2023-09-01 | gnu: utfcpp: Update to 3.2.4....* gnu/packages/textutils.scm (utfcpp): Update to 3.2.4.
[snippet]: Unbundle ftest.
[arguments]: Remove field.
[native-inputs]: Add ftest.
* gnu/packages/games.scm (warzone2100)[#:phases]: Adjust 'fix-utfcpp-include.
* gnu/packages/video.scm (mkvtoolnix)[#:phases]: Add 'fix-utfcpp-include.
Co-authored-by: Hilton Chain <hako@ultrarare.space>
Signed-off-by: Hilton Chain <hako@ultrarare.space>
| Reza Housseini |
2023-08-13 | gnu: ack: Update to 3.7.0....* gnu/packages/textutils.scm (ack): Update to 3.7.0.
Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
| Greg Hogan |