This patch provides an update so that nhc98 can be built and works with a modern C compiler (GCC 11) and libc (glibc 2.33). diff --git a/Makefile.inc b/Makefile.inc index 4fbd47a..5bce5c9 100644 --- a/Makefile.inc +++ b/Makefile.inc @@ -1,6 +1,10 @@ ### Configurable variables: -OPT = -O3 +# We want C89 semantics plus C++-style comments and things like the +# 'setjmp_buf' and 'u_short' types. More importantly, build with '-O1' +# only to avoid modern optimizations that break the code. +OPT = -O1 -std=gnu89 -D_GNU_SOURCE=1 + #ARCH = -m32 ARCH = diff --git a/script/nhc98heap.c b/script/nhc98heap.c index 534010e..a30d5cd 100644 --- a/script/nhc98heap.c +++ b/script/nhc98heap.c @@ -1,5 +1,6 @@ #include #include +#include main(int argc, char **argv) { int prefix = 1; diff --git a/src/runtime/Kernel/collector.c b/src/runtime/Kernel/collector.c index b95a273..1f879c5 100644 --- a/src/runtime/Kernel/collector.c +++ b/src/runtime/Kernel/collector.c @@ -2,6 +2,7 @@ #include #include #include +#include #include "node.h" /*#include "newmacros.h" -- already included in node.h */ /*#include "runtime.h" -- already included in node.h */ e78635b32bb0318835'>treecommitdiff
diff options
context:
space:
mode:
authorIvan Petkov <ivanppetkov@gmail.com>2019-01-27 22:50:46 -0800
committerDanny Milosavljevic <dannym@scratchpost.org>2019-02-14 17:56:30 +0100
commit0e9811f4a3a30c3496b17be78635b32bb0318835 (patch)
tree6743473c1dee36333917ff01b81640b15f7138ad
parent03d373202347617056ef103d356575d068123db8 (diff)
downloadguix-0e9811f4a3a30c3496b17be78635b32bb0318835.tar.gz
guix-0e9811f4a3a30c3496b17be78635b32bb0318835.zip
gnu: rust: Update to 1.29.2.
* gnu/packages/rust.scm (rust): Rename to... (rust-1.28): ...this. (rust): New variable.