The Guile process taking the role of PID 1 during Guix builds does not reap zombie processes, which makes them continue responding to "kill -0". --- a/src/testsuite/stop-server.sh 2015-02-05 11:24:00.535908842 +0100 +++ b/src/testsuite/stop-server.sh 2015-02-05 11:25:00.264351349 +0100 @@ -1,6 +1,21 @@ #!/bin/sh # ngIRCd Test Suite +process_is_alive(){ + ! process_is_dead "$1" && ! process_is_undead "$1" +} + +process_is_dead(){ + ! kill -0 "$1" +} + +process_is_undead(){ + case $(ps -p "$1" -o state=) in + (Z*) true ;; + (*) false ;; + esac +} + [ -z "$srcdir" ] && srcdir=`dirname $0` # read in functions @@ -24,7 +40,7 @@ # waiting ... for i in 1 2 3 4 5; do - kill -0 $pid > /dev/null 2>&1; r=$? + process_is_alive $pid > /dev/null 2>&1; r=$? if [ $r -ne 0 ]; then echo " ok". exit 0 Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/tests/monitoring.scm
AgeCommit message (Expand)Author
2023-05-06tests: Add missing module imports for marionette-evaluated code....Ludovic Courtès
2021-09-26tests: Reduce boilerplate for users of 'system-test-runner'....Ludovic Courtès
2021-09-25tests: Adjust to SRFI-64 as found in Guile 3.0.7....Ludovic Courtès
2021-04-12services: postgresql: Change service default socket directory....Christopher Baines
2021-02-01Merge branch 'staging'Leo Famulari
2021-01-28services: postgresql: Add socket directory support....Mathieu Othacehe
2021-01-04tests: monitoring: Use the latest postgresql for testing Zabbix....Leo Famulari
2020-10-20services: databases: Don't specify a default postgresql version....Christopher Baines
2020-10-20tests: monitoring: Use (service postgresql-service-type)....Christopher Baines
2020-07-15tests: zabbix: Fix typo in comment....Oleg Pykhalov