The Guile process taking the role of PID 1 during Guix builds does not reap
zombie processes, which makes them continue responding to "kill -0".
--- a/src/testsuite/stop-server.sh 2015-02-05 11:24:00.535908842 +0100
+++ b/src/testsuite/stop-server.sh 2015-02-05 11:25:00.264351349 +0100
@@ -1,6 +1,21 @@
#!/bin/sh
# ngIRCd Test Suite
+process_is_alive(){
+ ! process_is_dead "$1" && ! process_is_undead "$1"
+}
+
+process_is_dead(){
+ ! kill -0 "$1"
+}
+
+process_is_undead(){
+ case $(ps -p "$1" -o state=) in
+ (Z*) true ;;
+ (*) false ;;
+ esac
+}
+
[ -z "$srcdir" ] && srcdir=`dirname $0`
# read in functions
@@ -24,7 +40,7 @@
# waiting ...
for i in 1 2 3 4 5; do
- kill -0 $pid > /dev/null 2>&1; r=$?
+ process_is_alive $pid > /dev/null 2>&1; r=$?
if [ $r -ne 0 ]; then
echo " ok".
exit 0
e='submit' value='switch'/>
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2021-12-18 | import: cran: Fix description->package test....This follows up on commit 5cd1019488c44081aaf030fbe8bc357d78daef23.
* tests/cran.scm (description): Include a very long line.
(description->package): Update the golden description to match the
paragraph filling now performed by BEAUTIFY-DESCRIPTION.
| Tobias Geerinckx-Rice |
2021-07-11 | import: cran: Emit new-style package inputs....* guix/import/cran.scm (format-inputs): Emit symbols or
'specification->package' calls.
(maybe-inputs): Wrap in 'list' instead of 'quasiquote'.
* tests/cran.scm ("description->package"): Adjust accordingly.
| Ludovic Courtès |
2020-01-16 | import: cran: Avoid uses of '@@' in the tests....* guix/import/cran.scm (description->alist, description->package): Export.
<top level>: Set! 'listify'.
* tests/cran.scm (description-alist, "description->package"): Remove use
of '@@' to access the relevant bindings.
| Ludovic Courtès |