The Guile process taking the role of PID 1 during Guix builds does not reap zombie processes, which makes them continue responding to "kill -0". --- a/src/testsuite/stop-server.sh 2015-02-05 11:24:00.535908842 +0100 +++ b/src/testsuite/stop-server.sh 2015-02-05 11:25:00.264351349 +0100 @@ -1,6 +1,21 @@ #!/bin/sh # ngIRCd Test Suite +process_is_alive(){ + ! process_is_dead "$1" && ! process_is_undead "$1" +} + +process_is_dead(){ + ! kill -0 "$1" +} + +process_is_undead(){ + case $(ps -p "$1" -o state=) in + (Z*) true ;; + (*) false ;; + esac +} + [ -z "$srcdir" ] && srcdir=`dirname $0` # read in functions @@ -24,7 +40,7 @@ # waiting ... for i in 1 2 3 4 5; do - kill -0 $pid > /dev/null 2>&1; r=$? + process_is_alive $pid > /dev/null 2>&1; r=$? if [ $r -ne 0 ]; then echo " ok". exit 0 itch'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/NEWS
AgeCommit message (Expand)Author
2022-09-28Update NEWS....Mathieu Othacehe
2022-09-26NEWS: Update it....Mathieu Othacehe
2022-09-24Update NEWS.Ludovic Courtès
2022-09-23Update NEWS.Maxim Cournoyer
2022-09-19Update NEWS....Mathieu Othacehe
2022-09-16Update NEWS....Mathieu Othacehe
2022-09-15Update NEWS....Maxim Cournoyer
2022-09-14Update NEWS....Maxim Cournoyer
2021-11-23Update NEWS.Ludovic Courtès
2021-09-23Update NEWS....Tobias Geerinckx-Rice
2021-09-18Update NEWS.Ludovic Courtès
2021-07-07guix-install.sh: Prompt for configuring substitutes discovery....Maxim Cournoyer
2021-06-29pack: Add support for the deb format....Maxim Cournoyer
2021-05-10Update NEWS.Maxim Cournoyer
2021-05-10Update NEWS.Leo Famulari
2021-05-10Update NEWS.Ludovic Courtès
2021-05-04Update NEWS.Ludovic Courtès
2020-11-22Update NEWS.Ludovic Courtès
2020-11-13Update NEWS.Ludovic Courtès
2020-11-09Update NEWS.Ludovic Courtès
2020-11-07Update NEWS.Mathieu Othacehe
2020-11-07Update NEWS.Ludovic Courtès
2020-11-05Update NEWS.Ludovic Courtès