The Guile process taking the role of PID 1 during Guix builds does not reap zombie processes, which makes them continue responding to "kill -0". --- a/src/testsuite/stop-server.sh 2015-02-05 11:24:00.535908842 +0100 +++ b/src/testsuite/stop-server.sh 2015-02-05 11:25:00.264351349 +0100 @@ -1,6 +1,21 @@ #!/bin/sh # ngIRCd Test Suite +process_is_alive(){ + ! process_is_dead "$1" && ! process_is_undead "$1" +} + +process_is_dead(){ + ! kill -0 "$1" +} + +process_is_undead(){ + case $(ps -p "$1" -o state=) in + (Z*) true ;; + (*) false ;; + esac +} + [ -z "$srcdir" ] && srcdir=`dirname $0` # read in functions @@ -24,7 +40,7 @@ # waiting ... for i in 1 2 3 4 5; do - kill -0 $pid > /dev/null 2>&1; r=$? + process_is_alive $pid > /dev/null 2>&1; r=$? if [ $r -ne 0 ]; then echo " ok". exit 0 ubmit' value='switch'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/home.scm
AgeCommit message (Expand)Author
2022-08-19home: Fix docstring....Andrew Tropin
2022-08-01home: Add 'home-generation-base'....Ludovic Courtès
2022-07-17Revert "home: Add 'home-generation-base'."...Tobias Geerinckx-Rice
2022-07-23home: Add 'home-generation-base'....Ludovic Courtès
2021-12-19home: Add gexp-compiler for home-environments....Andrew Tropin
2021-10-09Move (gnu home-services) to (gnu home services)....Oleg Pykhalov
2021-10-08gnu: Move (gnu home-services) to (gnu home services)....Oleg Pykhalov
2021-09-09gnu: home: Add doc comment about the module....Andrew Tropin
2021-09-09home: Add home-environment....Andrew Tropin