Remove fixed search paths from autotools.
--- a/m4/package_utilies.m4 1970-01-01 01:00:01.000000000 +0100
+++ b/m4/package_utilies.m4 2020-07-07 12:41:48.871661042 +0200
@@ -23,32 +23,32 @@
AC_PACKAGE_NEED_UTILITY($1, "$cc", cc, [C compiler])
if test -z "$MAKE"; then
- AC_PATH_PROG(MAKE, gmake,, /usr/bin:/usr/freeware/bin)
+ AC_PATH_PROG(MAKE, gmake)
fi
if test -z "$MAKE"; then
- AC_PATH_PROG(MAKE, make,, /usr/bin)
+ AC_PATH_PROG(MAKE, make)
fi
make=$MAKE
AC_SUBST(make)
AC_PACKAGE_NEED_UTILITY($1, "$make", make, [GNU make])
if test -z "$LIBTOOL"; then
- AC_PATH_PROG(LIBTOOL, glibtool,, /usr/bin)
+ AC_PATH_PROG(LIBTOOL, glibtool)
fi
if test -z "$LIBTOOL"; then
- AC_PATH_PROG(LIBTOOL, libtool,, /usr/bin:/usr/local/bin:/usr/freeware/bin)
+ AC_PATH_PROG(LIBTOOL, libtool)
fi
libtool=$LIBTOOL
AC_SUBST(libtool)
AC_PACKAGE_NEED_UTILITY($1, "$libtool", libtool, [GNU libtool])
if test -z "$TAR"; then
- AC_PATH_PROG(TAR, tar,, /usr/freeware/bin:/bin:/usr/local/bin:/usr/bin)
+ AC_PATH_PROG(TAR, tar)
fi
tar=$TAR
AC_SUBST(tar)
if test -z "$ZIP"; then
- AC_PATH_PROG(ZIP, gzip,, /bin:/usr/local/bin:/usr/freeware/bin)
+ AC_PATH_PROG(ZIP, gzip)
fi
zip=$ZIP
@@ -61,25 +61,25 @@
AC_SUBST(makedepend)
if test -z "$AWK"; then
- AC_PATH_PROG(AWK, awk,, /bin:/usr/bin)
+ AC_PATH_PROG(AWK, awk)
fi
awk=$AWK
AC_SUBST(awk)
if test -z "$SED"; then
- AC_PATH_PROG(SED, sed,, /bin:/usr/bin)
+ AC_PATH_PROG(SED, sed)
fi
sed=$SED
AC_SUBST(sed)
if test -z "$ECHO"; then
- AC_PATH_PROG(ECHO, echo,, /bin:/usr/bin)
+ AC_PATH_PROG(ECHO, echo)
fi
echo=$ECHO
AC_SUBST(echo)
if test -z "$SORT"; then
- AC_PATH_PROG(SORT, sort,, /bin:/usr/bin)
+ AC_PATH_PROG(SORT, sort)
fi
sort=$SORT
AC_SUBST(sort)
/>
Age | Commit message (Expand) | Author |
2023-10-08 | disarchive-manifest: Add one manifest entry per tarball....This works around a situation where ‘cuirass remote-worker’ now builds
with max-jobs = 1 (Cuirass commit
980ef610989895be5ac2ba7f9d1901e5c7f22934). The effect is that all
.dis.drv would be performed sequentially, on a single machine (‘cuirass
remote-server’ is unable to distribute those derivations to several
machines because it only “sees” the ‘disarchive-collection’ derivation).
This would take a lot of time and force a rebuild of all of *.dis.drv
every time because their build results would not be retrieved by the
‘remote-server’ process.
* etc/disarchive-manifest.scm (disarchive-collection): Remove.
<top level>: Define ‘disarchives’. Append it to the entries of the
manifest.
| Ludovic Courtès |
2022-08-06 | disarchive-manifest: Exclude the Chromium tarball....* etc/disarchive-manifest.scm (disarchive-collection): Exclude
"chromium-" tarballs.
| Ludovic Courtès |
2022-08-05 | disarchive-manifest: Filter out origins without a hash....* etc/disarchive-manifest.scm (disarchive-collection): Filter out
origins with a phony hash.
| Ludovic Courtès |
2022-08-05 | disarchive-manifest: Handle tar.xz archives....* etc/disarchive-manifest.scm (tarball-origin?): Add ".tar.xz".
| Ludovic Courtès |
2021-10-09 | disarchive-manifest: Provide valid 'version' string....* etc/disarchive-manifest.scm <top level>: Turn 'version' field into a
string.
| Ludovic Courtès |
2021-09-14 | etc: Add 'disarchive-manifest.scm'....* etc/disarchive-manifest.scm: New file.
* Makefile.am (EXTRA_DIST): Add it.
| Ludovic Courtès |