Increase the timeout on dictionary tests to accommodate slower machines.
--- netsurf-3.6/test/hashtable.c
+++ netsurf-3.6/test/hashtable.c
@@ -286,6 +286,7 @@
tcase_add_checked_fixture(tc_dict_s,
dicts_hashtable_create,
dict_hashtable_teardown);
+ tcase_set_timeout(tc_dict_s, 30);
tcase_add_test(tc_dict_s, hashtable_dict_test);
@@ -297,6 +298,7 @@
tcase_add_checked_fixture(tc_dict_l,
dictl_hashtable_create,
dict_hashtable_teardown);
+ tcase_set_timeout(tc_dict_l, 30);
tcase_add_test(tc_dict_l, hashtable_dict_test);
form'>
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2021-09-21 | installer: keymap: Fix optional fields handling....Fixes: <https://issues.guix.gnu.org/50723>.
The keymap xml contains optional shortDescription and description fields. The
assoc-ref call on those fields can return false, handle it correctly.
* gnu/installer/keymap.scm (xkb-rules->models+layouts): Introduce a new
"maybe-empty" helper to deal with optional fields. Use it for shortDescription
and description fields.
| Mathieu Othacehe |
2020-04-09 | installer: Allow Alt+Shift toggle from non-Latin keyboard layouts....Fixes <https://bugs.gnu.org/40493>.
* gnu/installer/newt/keymap.scm (%non-latin-layouts): New variable.
(%non-latin-variants): New variable.
(%latin-layout+variants): New variable.
(toggleable-latin-layout): New procedure to compute combined layouts.
(run-keymap-page): Use it.
(keyboard-layout->configuration): Apply it in config.scm.
(run-layout-page): Mention Alt+Shift.
* gnu/installer/keymap.scm (kmscon-update-keymap): Pass on XKB options.
* gnu/installer/record.scm (<installer>): Adjust code comments.
* gnu/installer.scm (apply-keymap): Pass on XKB options.
(installer-steps): Adjust code comments.
* gnu/packages/patches/kmscon-runtime-keymap-switch.patch: Apply XKB options.
| Florian Pelz |