From: Tobias Geerinckx-Rice Date: Thu, 28 Feb 2019 20:29:00 +0100 Subject: [PATCH] netpbm: Fix CVE-2017-2587. Copied verbatim from Debian[0]. [0]: https://sources.debian.org/data/main/n/netpbm-free/2:10.78.05-0.1/debian/patches/netpbm-CVE-2017-2587.patch --- diff -urNp old/converter/other/svgtopam.c new/converter/other/svgtopam.c --- old/converter/other/svgtopam.c 2017-02-08 12:11:02.593690917 +0100 +++ new/converter/other/svgtopam.c 2017-02-08 13:49:38.319029371 +0100 @@ -771,12 +771,17 @@ createCanvas(unsigned int const width, MALLOCVAR_NOFAIL(canvasP); - canvasP->width = width; - canvasP->height = height; - canvasP->pixels = ppm_allocarray(width, height); - canvasP->maxval = maxval; + if(canvasP != NULL){ + canvasP->width = width; + canvasP->height = height; + canvasP->pixels = ppm_allocarray(width, height); + canvasP->maxval = maxval; + + *canvasPP = canvasP; + } else { + pm_error("can't allocate memory for canvas"); + } - *canvasPP = canvasP; } yrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/lisp-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 3bf1552d66..5beebdf311 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -17178,3 +17178,37 @@ any existing or future application.")
(define-public cl-flare
(sbcl-package->cl-source-package sbcl-flare))
+
+(define-public sbcl-simple-inferiors
+ (let ((commit "deac886354e03f8a9502ce96f12a0459ce3be671"))
+ (package
+ (name "sbcl-simple-inferiors")
+ (version (git-version "1.1.0" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Shinmera/simple-inferiors")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "08vsvqv3768bwb2y8mwxbw5wyqzzwqr7rd004r6gafdgf9p9mcx3"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("bordeaux-threads" ,sbcl-bordeaux-threads)
+ ("documentation-utils" ,sbcl-documentation-utils)))
+ (home-page "https://shinmera.github.io/simple-inferiors/")
+ (synopsis "Common Lisp library to use inferior processes")
+ (description
+ "This is a library to allow easy handling of external processes, and
+primarily to get their output. It handles proper copying of the standard and
+error outputs of the process simultaneously, both in a sequential and parallel
+fashion. It also features a lazy directory switching mechanism, to avoid
+running into parallelism problems when having to change directory.")
+ (license license:zlib))))
+
+(define-public ecl-simple-inferiors
+ (sbcl-package->ecl-package sbcl-simple-inferiors))
+
+(define-public cl-simple-inferiors
+ (sbcl-package->cl-source-package sbcl-simple-inferiors))