By default 'mutt' embeds configure flags and the output of 'gcc -v',
which contains the store file name of Bash and GCC. This patch makes
sure we don't embed a reference to these in 'mutt'.
--- mutt-1.5.23/txt2c.sh 2015-06-26 22:56:56.500731643 +0200
+++ mutt-1.5.23/txt2c.sh 2015-06-26 22:57:26.664583900 +0200
@@ -21,6 +21,8 @@ txt2c_fallback () {
echo ";"
}
+echo "unsigned char $1[] = \"value of '$1' not kept\";"
+exit 0
./txt2c test /dev/null 2>&1 &&
./txt2c "$1" ||
txt2c_fallback "$1"
href='/guix/'>guix
|
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2022-01-19 | etc: Match define-public only at line start....The current regexp simply matches the first occurence, which more often than
not points to the *previous* variable.
* etc/snippets/text-mode/guix-commit-message-update-package ($1): Restrict
match to beginning of line with optional indentation.
| Liliana Marie Prikler |
2021-06-26 | etc: snippets: Use ‘hg-file-name’ when origin uses ‘hg-fetch’...Adjust to changes in commit aaafd19bd1e37265de07e246286a6819792c25b4.
* etc/snippets/scheme-mode/guix-origin: Use ‘hg-file-name’ instead of
‘string-append’ when ‘method’ for origin is ‘hg-fetch’.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Xinglu Chen |