Mupen64Plus supports a single data directory and a single plugin directory in
its configuration, yet we need data and plugin files from a variety of
packages. The best way to deal with this is to install all packages from
which data and plugin files are needed into one's profile, and point the
configuration there. Hence, the ui-console package provides propagated inputs
for packages with the most important data and plugin files, and this patch
provides the user instructions on what needs to be done in order to have
Mupen64Plus find the relevant data and plugins.
--- a/src/plugin.c
+++ b/src/plugin.c
@@ -122,6 +122,22 @@ m64p_error PluginSearchLoad(m64p_handle ConfigUI)
{
const char *plugindir = (*ConfigGetParamString)(ConfigUI, "PluginDir");
lib_filelist = osal_library_search(plugindir);
+ /* Guix specific */
+ if (lib_filelist == NULL)
+ {
+ DebugMessage(M64MSG_ERROR, "No plugins found in PluginDir path: %s", plugindir);
+ DebugMessage(M64MSG_ERROR,
+ "\n\n"
+ "*********************************\n"
+ "*** Notice for GNU Guix users ***\n"
+ "*********************************\n"
+ "\n"
+ "You might want to edit your mupen64plus.cfg (in $XDG_CONFIG_HOME by default)\n"
+ "and set SharedDataPath to /path/to/my_guix_profile/share/mupen64plus and\n"
+ "PluginDir to /path/to/my_guix_profile/lib/mupen64plus so that data and plugins\n"
+ "are found.\n"
+ "\n");
+ }
}
/* if still no plugins found, search some common system folders */
author
services: gnome: Add udev rules....Fixes: <https://issues.guix.gnu.org/32166>.
* gnu/services/desktop.scm (gnome-packages, gnome-udev-rules): New procedures.
(gnome-polkit-settings): Use the gnome-packages procedure.
(gnome-desktop-service-type): Add an udev service extension.
Mathieu Othacehe
2021-12-08
services: %desktop-services: Use SDDM rather than GDM on non-x86_64....This works around the fact that Rust is currently unavailable in Guix on
platforms other than x86_64-linux:
https://lists.gnu.org/archive/html/guix-devel/2021-11/msg00197.html
* gnu/services/desktop.scm (desktop-services-for-system): New
procedure.
(%desktop-services): Turn into a macro.
Ludovic Courtès
2021-10-03
services: desktop: Add the sticky bit to the X11 socket directory....This prevents mutter from complaining that the /tmp/.X11-unix directory
misses the sticky bit when starting X Wayland.
* gnu/services/desktop.scm (x11-socket-directory-service): Add the sticky bit.
Mathieu Othacehe
2021-07-29
services: Migrate to <setuid-program>....* gnu/services/dbus.scm (dbus-setuid-programs, polkit-setuid-programs):
Return setuid-programs.
* gnu/services/desktop.scm (enlightenment-setuid-programs): Return
setuid-programs.
(%desktop-services)[mount-setuid-helpers]: Use setuid-programs.
* gnu/services/docker.scm (singularity-setuid-programs): Return
setuid-programs.
* gnu/services/xorg.scm(screen-locker-setuid-programs): Return
setuid-programs.
* gnu/system.scm (%setuid-programs): Return setuid-programs.
* doc/guix.texi (Setuid Programs, operating-system Reference): Replace
'list of G-expressions' with 'list of <setuid-program>'.
Brice Waegeneire
2021-06-14
services: Remove deprecated service procedures....These service procedures were deprecated in January 2019, for instance
in commit 65a67bf711b14bc7200f6730c0f173375ca12974.
* gnu/services/avahi.scm (avahi-service): Remove.
* gnu/services/base.scm (console-keymap, guix-service)
(guix-publish-service, gpm-service, urandom-seed-service): Remove.
* gnu/services/desktop.scm (upower-service, colord-service): Remove.
* gnu/services/mcron.scm (mcron-service): Remove.
* gnu/services/messaging.scm (bitlbee-service): Remove.
* gnu/services/networking.scm (dhcp-client-service, ntp-service)
(tor-service): Remove.
* gnu/services/xorg.scm (slim-service, gdm-service): Remove.