Create a shared version of the sequential library, MUST BE LAST IN SERIES
Index: mumps/libseq/Makefile
===================================================================
--- mumps.orig/libseq/Makefile
+++ mumps/libseq/Makefile
@@ -8,15 +8,17 @@ all: libmpiseq
include ../Makefile.inc
-libmpiseq: libmpiseq$(PLAT)$(LIBEXT)
+libmpiseq: libmpiseq$(PLAT).a libmpiseq$(PLAT).so
-libmpiseq$(PLAT)$(LIBEXT): mpi.o mpic.o elapse.o
- $(AR)$@ mpi.o mpic.o elapse.o
+libmpiseq$(PLAT).a: mpi.o mpic.o elapse.o
+ $(AR) $@ mpi.o mpic.o elapse.o
$(RANLIB) $@
+libmpiseq$(PLAT).so: mpi.o mpic.o elapse.o
+ $(FC) -shared $^ -Wl,-soname,libmpiseq$(PLAT)-5.1.2.so -o libmpiseq$(PLAT)-5.1.2.so -Wl,-z,defs
.f.o:
- $(FC) $(OPTF) -c $*.f $(OUTF)$*.o
+ $(FC) $(OPTF) -fPIC -c $*.f $(OUTF)$*.o
.c.o:
- $(CC) $(OPTC) $(CDEFS) -I. -c $*.c $(OUTC)$*.o
+ $(CC) $(OPTC) $(CDEFS) -I. -fPIC -c $*.c $(OUTC)$*.o
clean:
- $(RM) *.o *$(LIBEXT)
+ $(RM) *.o *.a *.so
Index: mumps/Makefile
===================================================================
--- mumps.orig/Makefile
+++ mumps/Makefile
@@ -60,6 +60,7 @@ requiredobj: Makefile.inc $(LIBSEQNEEDED
libseqneeded:
(cd libseq; $(MAKE))
+ cp libseq/lib* $(libdir)
# Build the libpord.a library and copy it into $(topdir)/lib
$(libdir)/libpord$(PLAT).a:
>commitdiff
|
Age | Commit message (Expand) | Author |
2023-03-28 | NEWS: Mention new rpm format....* NEWS (Package management): Mention new rpm format.
| Maxim Cournoyer |
2022-12-18 | Update NEWS. | Ludovic Courtès |
2022-12-17 | Update NEWS. | Marius Bakke |
2022-12-02 | Update NEWS. | Ludovic Courtès |
2022-11-23 | NEWS: Update it....* NEWS: Shepherd is already at 0.9.3 now.
| Jonathan Brielmaier |
2022-11-16 | Update NEWS. | Maxim Cournoyer |
2022-10-13 | NEWS: Update it....* NEWS: Add an entry about 'guix shell' --emulate-fhs option.
| Mathieu Othacehe |
2022-10-07 | Update NEWS....* NEWS: Add new entry for installation script improvements.
| Maxim Cournoyer |
2022-09-28 | Update NEWS....* NEWS: Add new services for the 1.4.0.
| Mathieu Othacehe |
2022-09-26 | NEWS: Update it....* NEWS: Add an entry about WSL images.
| Mathieu Othacehe |
2022-09-24 | Update NEWS. | Ludovic Courtès |
2022-09-23 | Update NEWS. | Maxim Cournoyer |
2022-09-19 | Update NEWS....* NEWS: Mention Shepherd 0.9.2 upgrade.
| Mathieu Othacehe |
2022-09-16 | Update NEWS....Entries extracted from:
git log 3eadcdc63..version-1.4.0
* NEWS: Update entries for v1.4.0
| Mathieu Othacehe |
2022-09-15 | Update NEWS....This covers the commits made between v1.3.0..3eadcdc6^.
* NEWS: New entries for the 1.4.0 upcoming release.
| Maxim Cournoyer |
2022-09-14 | Update NEWS....These news were extracted from the output of:
git log --reverse v1.3.0..03eb0b1be2cfedd0d9a66fef0edc53a17f7653a5.
* NEWS: Update entries for v1.4.0.
| Maxim Cournoyer |