Create a shared version of the sequential library, MUST BE LAST IN SERIES Index: mumps/libseq/Makefile =================================================================== --- mumps.orig/libseq/Makefile +++ mumps/libseq/Makefile @@ -8,15 +8,17 @@ all: libmpiseq include ../Makefile.inc -libmpiseq: libmpiseq$(PLAT)$(LIBEXT) +libmpiseq: libmpiseq$(PLAT).a libmpiseq$(PLAT).so -libmpiseq$(PLAT)$(LIBEXT): mpi.o mpic.o elapse.o - $(AR)$@ mpi.o mpic.o elapse.o +libmpiseq$(PLAT).a: mpi.o mpic.o elapse.o + $(AR) $@ mpi.o mpic.o elapse.o $(RANLIB) $@ +libmpiseq$(PLAT).so: mpi.o mpic.o elapse.o + $(FC) -shared $^ -Wl,-soname,libmpiseq$(PLAT)-5.2.1.so -o libmpiseq$(PLAT)-5.2.1.so -Wl,-z,defs .f.o: - $(FC) $(OPTF) -c $*.f $(OUTF)$*.o + $(FC) $(OPTF) -fPIC -c $*.f $(OUTF)$*.o .c.o: - $(CC) $(OPTC) $(CDEFS) -I. -c $*.c $(OUTC)$*.o + $(CC) $(OPTC) $(CDEFS) -I. -fPIC -c $*.c $(OUTC)$*.o clean: - $(RM) *.o *$(LIBEXT) + $(RM) *.o *.a *.so Index: mumps/Makefile =================================================================== --- mumps.orig/Makefile +++ mumps/Makefile @@ -60,6 +60,7 @@ requiredobj: Makefile.inc $(LIBSEQNEEDED libseqneeded: (cd libseq; $(MAKE)) + cp libseq/lib* $(libdir) # Build the libpord.a library and copy it into $(topdir)/lib $(libdir)/libpord$(PLAT).a: dd5e087'>treecommitdiff
path: root/gnu/packages/nutrition.scm
7682abe06'>Collapse)
AgeCommit message (Expand)Author
Author
2023-11-07doc: Add some guidelines for reviewing.Maxim Cournoyer
* doc/contributing.texi (Contributing) [Reviewing the Work of Others]: New section. (Debbugs Usertags): Expound with Emacs Debbugs information and document the 'reviewed-looks-good' usertag. * etc/git/gitconfig [b4]: New section. Change-Id: I56630b15ec4fbc5c67e5420dbf2838556a005d6b Reviewed-by: Ludovic Courtès <ludo@gnu.org>
2023-05-18etc: gitconfig: Do not enforced signed commits.Maxim Cournoyer
This change was more invasive than initially thought, and cannot be disabled easily, as raised by a few people. Let's revert it for now. At least the pre-push hook should be deployed automatically and catch any unsigned commits attempted to be pushed to Savannah. * etc/git/gitconfig [commit]: Remove section.
2023-05-01Makefile.am: Auto-configure Git on 'make'.Maxim Cournoyer
This means we do not need to worry anymore about manually syncing the pre-push git hook or the Guix-provided git configuration. * etc/git/gitconfig: Augment configuration template with useful options to allow for auto-configuration. * Makefile.am (.git/hooks/pre-push, .git/config): New targets. (nodist_noinst_DATA): New primary variable holding the above targets.
2021-10-14Add git configuration templates to improve diff hunk header detection.Sarah Morgensen
This is a follow-up to commit 9fc8ae4171e5da4939a64fc6d684c8b9d85bbe84, which missed two hunks from <https://issues.guix.gnu.org/50363>. Reported by hackeryarn on #guix. * .gitattributes, etc/git/gitconfig: New files. Signed-off-by: Marius Bakke <marius@gnu.org>