Create a shared version of the sequential library, MUST BE LAST IN SERIES Index: mumps/libseq/Makefile =================================================================== --- mumps.orig/libseq/Makefile +++ mumps/libseq/Makefile @@ -8,15 +8,17 @@ all: libmpiseq include ../Makefile.inc -libmpiseq: libmpiseq$(PLAT)$(LIBEXT) +libmpiseq: libmpiseq$(PLAT).a libmpiseq$(PLAT).so -libmpiseq$(PLAT)$(LIBEXT): mpi.o mpic.o elapse.o - $(AR)$@ mpi.o mpic.o elapse.o +libmpiseq$(PLAT).a: mpi.o mpic.o elapse.o + $(AR) $@ mpi.o mpic.o elapse.o $(RANLIB) $@ +libmpiseq$(PLAT).so: mpi.o mpic.o elapse.o + $(FC) -shared $^ -Wl,-soname,libmpiseq$(PLAT)-5.2.1.so -o libmpiseq$(PLAT)-5.2.1.so -Wl,-z,defs .f.o: - $(FC) $(OPTF) -c $*.f $(OUTF)$*.o + $(FC) $(OPTF) -fPIC -c $*.f $(OUTF)$*.o .c.o: - $(CC) $(OPTC) $(CDEFS) -I. -c $*.c $(OUTC)$*.o + $(CC) $(OPTC) $(CDEFS) -I. -fPIC -c $*.c $(OUTC)$*.o clean: - $(RM) *.o *$(LIBEXT) + $(RM) *.o *.a *.so Index: mumps/Makefile =================================================================== --- mumps.orig/Makefile +++ mumps/Makefile @@ -60,6 +60,7 @@ requiredobj: Makefile.inc $(LIBSEQNEEDED libseqneeded: (cd libseq; $(MAKE)) + cp libseq/lib* $(libdir) # Build the libpord.a library and copy it into $(topdir)/lib $(libdir)/libpord$(PLAT).a: >diff
path: root/m4
AgeCommit message (Expand)Author
2023-03-16build: Correct guix_system on musl libc distros....Antero Mejr
2022-01-14gnu: bootstrap: Add support for riscv64-linux....Efraim Flashner
2021-12-14build: Adjust 'courage level' of different systems....Efraim Flashner
2021-05-23gnu: bootstrap: Add support for powerpc-linux....Efraim Flashner
2021-03-23Add powerpc64le-linux as a supported Guix architecture....Chris Marusich
2021-03-17maint: Check whether Guile-zlib is recent enough....Ludovic Courtès
2021-02-04build: Add '--with-channel-commit' and related configure flags....Ludovic Courtès
2020-12-11maint: Avoid macros obsolete in Autoconf 2.70....Ludovic Courtès
2020-10-22git: Require Guile-Git 0.3.0 or later....Ludovic Courtès
2020-09-08Remove (guix json) and require Guile-JSON 4.3.0+....Ludovic Courtès
2020-08-29build: Remove check for Guile 2.2.1 bug....Ludovic Courtès
2020-08-24Use "guile-zlib" and "guile-lzlib" instead of (guix config)....Mathieu Othacehe
2020-07-20ssh: Speed up RPCs by using #:nodelay....Lars-Dominik Braun