Building sublibraries in parallel can lead to race conditions on the libseq
and lipord targets.
--- MUMPS_5.0.0/Makefile.orig 2015-06-15 10:08:54.523146562 -0500
+++ MUMPS_5.0.0/Makefile 2015-06-15 10:19:44.074367512 -0500
@@ -11,6 +11,7 @@
sexamples dexamples cexamples zexamples \
mumps_lib requiredobj libseqneeded clean
+.NOTPARALLEL:
alllib: c z s d
all: cexamples zexamples sexamples dexamples
iv id='cgit'>
Age | Commit message (Expand) | Author |
2022-03-04 | validate repository responses against JSON schemas...* compute_scripts.awk (include_file): don't enforce specific path format on #INCLUDE'd files
* .gitmodules, schemas: add Haketilo JSON schemas subrepo
* html/install.js (InstallView): import schema validator and run it against downloaded mapping and resource definitions
* html/repo_query.js (RepoEntry): import schema validator and run it against obtained query results
* test/haketilo_test/unit/test_install.py (test_install_normal_usage, test_install_dialogs): use underscore instead of hyphen in item identifiers
* test/haketilo_test/unit/test_install.py (test_install_dialogs): adapt error message test cases to new handling method of invalid JSON instanced
* test/haketilo_test/unit/test_repo_query.py (test_repo_query_normal_usage): use underscore instead of hyphen in item identifiers
* test/haketilo_test/unit/test_repo_query.py (test_repo_query_messages): use higher sample unsupported schema version to avoid having to modify the test case soon
* test/haketilo_test/world_wide_library.py: use underscore instead of hyphen in item identifiers
* common/jsonschema.js, common/jsonschema: adapt tdegrunt's jsonschema and include in Haketilo, load schema documents from schemas/
| Wojtek Kosior |