This patch was downloaded from https://sourceforge.net/p/mpg321/bugs/51/ and fixes CVE-2019-14247. Description: Handle illegal bitrate value Author: Chrysostomos Nanakos Bug-Debian: https://bugs.debian.org/870406 Bug-Debian: https://bugs.debian.org/887057 --- mpg321-0.3.2.orig/mad.c +++ mpg321-0.3.2/mad.c @@ -574,6 +574,12 @@ void scan(void const *ptr, ssize_t len, if (!is_vbr) { + if (header.bitrate <= 0) + { + fprintf(stderr, "Illegal bit allocation value\n"); + return; + } + double time = (len * 8.0) / (header.bitrate); /* time in seconds */ double timefrac = (double)time - ((long)(time)); long nsamples = 32 * MAD_NSBSAMPLES(&header); /* samples per frame */ ix/about/'>aboutsummaryrefslogtreecommitdiff
path: root/tests/inferior.scm
AgeCommit message (Expand)Author
2019-02-12inferior: Add 'inferior-available-packages'....Ludovic Courtès
2018-11-28inferior: Add 'inferior-eval-with-store'....Ludovic Courtès
2018-09-21profiles: 'packages->manifest' now accepts inferior packages....Ludovic Courtès
2018-09-21inferior: Add 'inferior-package->manifest-entry'....Ludovic Courtès
2018-09-21inferior: Add 'inferior-package-search-paths' & co....Ludovic Courtès
2018-09-21inferior: Add 'inferior-package-inputs' & co....Ludovic Courtès
2018-09-21inferior: Add 'lookup-inferior-packages'....Ludovic Courtès
2018-09-21inferior: Add 'inferior-package-derivation'....Ludovic Courtès
2018-09-04inferior: Add home-page and location package accessors....Ludovic Courtès
2018-07-13Add (guix inferior) and (guix scripts repl)....Ludovic Courtès