--- a/src/CMakeLists.txt 2021-05-28 13:07:25.655107983 +0200 +++ b/src/CMakeLists.txt 2021-05-28 13:09:55.764025497 +0200 @@ -21,24 +21,6 @@ -### Link HTSlib - -ExternalProject_Add(htslib - PREFIX ${CMAKE_BINARY_DIR}/htslib - GIT_REPOSITORY "https://github.com/samtools/htslib.git" - GIT_TAG "1.3.1" - UPDATE_COMMAND "" - BUILD_IN_SOURCE 1 - CONFIGURE_COMMAND "" - BUILD_COMMAND make - INSTALL_COMMAND make install prefix=${CMAKE_BINARY_DIR}/htslib - LOG_DOWNLOAD 1 -) -link_directories (${CMAKE_BINARY_DIR}/htslib/lib) -include_directories (${CMAKE_BINARY_DIR}/htslib/include) - - - ### Set version # Get the current working branch @@ -64,13 +46,6 @@ # 2. Boost version from find_package (Boost_VERSION) -# 3. Get HTSlib version from git -execute_process( - COMMAND git describe --always - WORKING_DIRECTORY ${PROJECT_BINARY_DIR}/htslib - OUTPUT_VARIABLE HTSLIB_VERSION - OUTPUT_STRIP_TRAILING_WHITESPACE -) set(HTSLIB_VERSION "1.3.1 ${HTSLIB_VERSION}") # 4. write version.hpp file @@ -105,7 +80,6 @@ add_executable (mosaic main.cpp ${HEADER_FILES}) target_link_libraries (mosaic LINK_PUBLIC ${Boost_LIBRARIES}) target_link_libraries (mosaic LINK_PUBLIC hts) -add_dependencies (mosaic htslib) ### Doxygen API documentation 33f916d804aed9961c57'>treecommitdiff
path: root/gnu/packages/hardware.scm
AgeCommit message (Expand)Author
2019-03-24gnu: ddcutil: Update to 0.9.5....Tobias Geerinckx-Rice
2019-02-17gnu: wavemon: Update to 0.9.0....Tobias Geerinckx-Rice
2019-02-17gnu: ddcutil: Update to 0.9.4....Tobias Geerinckx-Rice
2018-10-24gnu: Add wavemon....Tobias Geerinckx-Rice
2018-10-04gnu: ddcutil: Update to 0.9.2....Tobias Geerinckx-Rice
2018-10-04gnu: Add memtester....Tobias Geerinckx-Rice
2018-10-04gnu: Add memtest86+....Tobias Geerinckx-Rice
2018-08-30gnu: Add msr-tools....Tobias Geerinckx-Rice
2018-08-30gnu: Add ddcutil....Tobias Geerinckx-Rice