--- a/src/CMakeLists.txt 2021-05-28 13:07:25.655107983 +0200
+++ b/src/CMakeLists.txt 2021-05-28 13:09:55.764025497 +0200
@@ -21,24 +21,6 @@
-### Link HTSlib
-
-ExternalProject_Add(htslib
- PREFIX ${CMAKE_BINARY_DIR}/htslib
- GIT_REPOSITORY "https://github.com/samtools/htslib.git"
- GIT_TAG "1.3.1"
- UPDATE_COMMAND ""
- BUILD_IN_SOURCE 1
- CONFIGURE_COMMAND ""
- BUILD_COMMAND make
- INSTALL_COMMAND make install prefix=${CMAKE_BINARY_DIR}/htslib
- LOG_DOWNLOAD 1
-)
-link_directories (${CMAKE_BINARY_DIR}/htslib/lib)
-include_directories (${CMAKE_BINARY_DIR}/htslib/include)
-
-
-
### Set version
# Get the current working branch
@@ -64,13 +46,6 @@
# 2. Boost version from find_package (Boost_VERSION)
-# 3. Get HTSlib version from git
-execute_process(
- COMMAND git describe --always
- WORKING_DIRECTORY ${PROJECT_BINARY_DIR}/htslib
- OUTPUT_VARIABLE HTSLIB_VERSION
- OUTPUT_STRIP_TRAILING_WHITESPACE
-)
set(HTSLIB_VERSION "1.3.1 ${HTSLIB_VERSION}")
# 4. write version.hpp file
@@ -105,7 +80,6 @@
add_executable (mosaic main.cpp ${HEADER_FILES})
target_link_libraries (mosaic LINK_PUBLIC ${Boost_LIBRARIES})
target_link_libraries (mosaic LINK_PUBLIC hts)
-add_dependencies (mosaic htslib)
### Doxygen API documentation
df47'>treecommitdiff
|
Age | Commit message (Expand) | Author |
2021-12-13 | gnu: Simplify package inputs....This commit was obtained by running:
./pre-inst-env guix style
without any additional argument.
| Ludovic Courtès |
2021-01-28 | gnu: libgdiplus: Update to 6.0.5....* gnu/packages/mono.scm (libgdiplus): Update to 6.0.5.
Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
| Vincent Legoll |