--- mono-4.4.1/mcs/class/monodoc/Monodoc/storage/ZipStorage.cs.orig 2018-11-26 22:16:25.008879747 +0100 +++ mono-4.4.1/mcs/class/monodoc/Monodoc/storage/ZipStorage.cs 2018-11-26 22:21:53.969770985 +0100 @@ -74,6 +74,12 @@ id = GetNewCode (); ZipEntry entry = new ZipEntry (id); + var SOURCE_DATE_EPOCH_string = Environment.GetEnvironmentVariable("SOURCE_DATE_EPOCH"); + if (SOURCE_DATE_EPOCH_string != null) + { + var SOURCE_DATE_EPOCH = Convert.ToInt64(SOURCE_DATE_EPOCH_string); + entry.DateTime = new DateTime(SOURCE_DATE_EPOCH, DateTimeKind.Utc); + } zipOutput.PutNextEntry (entry); } name='id' value='ef05c6df02becb2e5849f23fa0d456b07122fa5e'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/build-aux/build-self.scm
AgeCommit message (Expand)Author
2019-07-16Use more guix.gnu.org....Tobias Geerinckx-Rice
2019-05-12build-self: Let HOME pass through the execution environment....Ludovic Courtès
2019-05-11Revert "build-self: Let HOME pass through the execution environment."...Tobias Geerinckx-Rice
2019-05-11build-self: Let HOME pass through the execution environment....Ludovic Courtès
2019-04-23build-self: Explain why we keep using deprecated bindings....Ludovic Courtès
2019-04-23Revert "build-self: Avoid deprecated bindings."...Ludovic Courtès
2019-04-22build-self: Avoid deprecated bindings....Mark H Weaver
2019-04-17self: Remove unused variable....Ludovic Courtès
2019-03-26build-self: Disable position recording....Ludovic Courtès