--- mono-4.4.1/mcs/class/monodoc/Monodoc/storage/ZipStorage.cs.orig 2018-11-26 22:16:25.008879747 +0100 +++ mono-4.4.1/mcs/class/monodoc/Monodoc/storage/ZipStorage.cs 2018-11-26 22:21:53.969770985 +0100 @@ -74,6 +74,12 @@ id = GetNewCode (); ZipEntry entry = new ZipEntry (id); + var SOURCE_DATE_EPOCH_string = Environment.GetEnvironmentVariable("SOURCE_DATE_EPOCH"); + if (SOURCE_DATE_EPOCH_string != null) + { + var SOURCE_DATE_EPOCH = Convert.ToInt64(SOURCE_DATE_EPOCH_string); + entry.DateTime = new DateTime(SOURCE_DATE_EPOCH, DateTimeKind.Utc); + } zipOutput.PutNextEntry (entry); } ' value='387b86ff003b051945ab08030169228556cc2a4a'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gdb.scm
AgeCommit message (Expand)Author
2023-06-17gnu: Use target-hurd?, system-hurd? instead of hurd-target?, hurd-system?....* gnu/packages/hurd.scm (hurd-target?): Remove. (hurd-system?): Move to... * guix/utils.scm (system-hurd?): ...here. * gnu/packages/*: Update all users, removing (gnu packages hurd) include where now unused. Janneke Nieuwenhuizen
2023-05-07gnu: gdb/pinned: Move to gdb-12.1....* gnu/packages/gdb.scm (gdb/pinned): Refer to gdb-12.1. [properties]: Hide the package. (gdb-12): Inherit from gdb/pinned. Efraim Flashner
2023-04-18gnu: gdb: Change default to 12.x....* gnu/packages/gdb.scm (gdb): Change to GDB-12. Ludovic Courtès
2023-04-18gnu: gdb: Distinguish between the "pinned" and the "default" version....* gnu/packages/gdb.scm (gdb/pinned): New variable. * gnu/packages/rust.scm (rust)[native-inputs]: Use it instead of GDB. Ludovic Courtès
2023-04-18gnu: gdb: Remove Hurd patch....The patch was useful for GDB 11 on the previous Hurd version that was used; it's unnecessary on GDB 12 and GDB 11 has other build issues on the current GNU/Hurd. This change fixes "guix build gdb-minimal --target=i586-pc-gnu". * gnu/packages/patches/gdb-fix-gnu-nat-build.patch: Remove. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/gdb.scm (gdb-11)[arguments]: Remove 'patch-gdb/hurd' phase. [inputs]: Remove "hurd-build.patch" input. [supported-systems]: New field. (gdb-12)[supported-systems]: New field. Ludovic Courtès
2023-04-18gnu: gdb-minimal: Update to 12.x....* gnu/packages/gdb.scm (gdb-minimal): Rebase on GDB-12. Ludovic Courtès
2023-04-18gnu: gdb: Use 'cross-mig' when targeting GNU/Hurd....This is a followup to 2756d662aa27cf55f3224e4a0a9e08c1be2cc551. * gnu/packages/gdb.scm (gdb-11)[native-inputs]: Use 'cross-mig' instead of 'mig/32-bit'. Ludovic Courtès