From eb2079d467f8658eea13e2ed86cc69d864632866 Mon Sep 17 00:00:00 2001 From: Vinicius Monego Date: Wed, 29 Sep 2021 19:07:35 -0300 Subject: [PATCH] Use system googletest and benchmark. --- CMakeLists.txt | 13 +++---------- 1 file changed, 3 insertions(+), 10 deletions(-) diff --git a/CMakeLists.txt b/CMakeLists.txt index 10e9b0a..492ccae 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt @@ -1467,12 +1467,7 @@ set(gtest_force_shared_crt ON CACHE BOOL "Pass Mixxx compiler/linker options to # Prevent installation of GoogleTest libraries set(INSTALL_GTEST OFF CACHE BOOL "Disable installation of GoogleTest" FORCE) -# Add googletest directly to our build. This adds the following targets: -# gtest, gtest_main, gmock and gmock_main -add_subdirectory( - "${CMAKE_CURRENT_SOURCE_DIR}/lib/googletest" - "${CMAKE_CURRENT_BINARY_DIR}/lib/googletest" -) +find_package(GTest CONFIG REQUIRED) add_executable(mixxx-test src/test/analyserwaveformtest.cpp @@ -1582,10 +1577,8 @@ set(BENCHMARK_ENABLE_TESTING OFF CACHE BOOL "" FORCE) # Prevent installation of google/benchmark artifacts set(BENCHMARK_ENABLE_INSTALL OFF CACHE BOOL "Disable installation of google/benchmark" FORCE) -add_subdirectory( - "${CMAKE_CURRENT_SOURCE_DIR}/lib/benchmark" - "${CMAKE_CURRENT_BINARY_DIR}/lib/benchmark" -) +find_package(benchmark CONFIG REQUIRED) + target_link_libraries(mixxx-test PRIVATE benchmark) # Test Suite -- 2.30.2 og/'>
;;; copyright.el --- Insert a Guix copyright.

;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>

;; This file is part of GNU Guix.

;; GNU Guix is free software; you can redistribute it and/or modify
;; it under the terms of the GNU General Public License as published by
;; the Free Software Foundation, either version 3 of the License, or
;; (at your option) any later version.

;; GNU Guix is distributed in the hope that it will be useful,
;; but WITHOUT ANY WARRANTY; without even the implied warranty of
;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;; GNU General Public License for more details.

;; You should have received a copy of the GNU General Public License
;; along with this program.  If not, see <http://www.gnu.org/licenses/>.

;;; Commentary:

;; This package provides skeleton to insert a copyright with `guix-copyright'.

;;; Code:

(define-skeleton guix-copyright
  "Insert a copyright by $USER notice at cursor."
  "FULL_NAME <MAIL_ADDRESS>: "
  comment-start
  ";; Copyright © " `(format-time-string "%Y") " "
  (or (format "%s <%s>" user-full-name user-mail-address) str)
  comment-end)

;;; copyright.el ends here