Fix a null pointer dereference when no DNS search path is configured. This showed up as a segfault while running the gsasl test suite. Taken from upstream: https://github.com/krb5/krb5/commit/cd82bf377e7fad2409c76bf8b241920692f34fda diff --git a/src/lib/krb5/os/dnsglue.c b/src/lib/krb5/os/dnsglue.c index e35ca9d76c..0cd213fdd7 100644 --- a/src/lib/krb5/os/dnsglue.c +++ b/src/lib/krb5/os/dnsglue.c @@ -91,7 +91,7 @@ static int initparse(struct krb5int_dns_state *); #define DECLARE_HANDLE(h) struct __res_state h #define INIT_HANDLE(h) (memset(&h, 0, sizeof(h)), res_ninit(&h) == 0) #define SEARCH(h, n, c, t, a, l) res_nsearch(&h, n, c, t, a, l) -#define PRIMARY_DOMAIN(h) strdup(h.dnsrch[0]) +#define PRIMARY_DOMAIN(h) ((h.dnsrch[0] == NULL) ? NULL : strdup(h.dnsrch[0])) #if HAVE_RES_NDESTROY #define DESTROY_HANDLE(h) res_ndestroy(&h) #else @@ -104,7 +104,8 @@ static int initparse(struct krb5int_dns_state *); #define DECLARE_HANDLE(h) #define INIT_HANDLE(h) (res_init() == 0) #define SEARCH(h, n, c, t, a, l) res_search(n, c, t, a, l) -#define PRIMARY_DOMAIN(h) strdup(_res.defdname) +#define PRIMARY_DOMAIN(h) \ + ((_res.defdname == NULL) ? NULL : strdup(_res.defdname)) #define DESTROY_HANDLE(h) #endif /guix/tree/build-aux/hydra/evaluate.scm?id=6bfbdc949c6d463eb96db4555e30037ce4769ba6'>treecommitdiff
path: root/build-aux/hydra/evaluate.scm
ce
AgeCommit message (Expand)Author
2020-03-22Remove workaround for 'time-monotonic' in Guile 2.2.2....Ludovic Courtès
2020-03-22hydra: evaluate: Use 'with-build-handler'....Ludovic Courtès
2019-01-06hydra: evaluate: Add the checkout to the store....Ludovic Courtès
2018-04-08hydra: 'guix-modular' jobs use the new 'build-self'....Ludovic Courtès
2017-11-21hydra: 'evaluate' passes an alist to the entry point....Ludovic Courtès
2017-09-28cuirass: Add 'cuirass-jobs.scm' target to compute the Cuirass jobs....Jan Nieuwenhuizen
2017-05-07maint: Add 'time-monotonic' bug workaround in build-aux/hydra/evaluate.scm....Ludovic Courtès
2019-06-10services: Add 'nix-service-type'....Oleg Pykhalov