Fix a null pointer dereference when no DNS search path is configured. This showed up as a segfault while running the gsasl test suite. Taken from upstream: https://github.com/krb5/krb5/commit/cd82bf377e7fad2409c76bf8b241920692f34fda diff --git a/src/lib/krb5/os/dnsglue.c b/src/lib/krb5/os/dnsglue.c index e35ca9d76c..0cd213fdd7 100644 --- a/src/lib/krb5/os/dnsglue.c +++ b/src/lib/krb5/os/dnsglue.c @@ -91,7 +91,7 @@ static int initparse(struct krb5int_dns_state *); #define DECLARE_HANDLE(h) struct __res_state h #define INIT_HANDLE(h) (memset(&h, 0, sizeof(h)), res_ninit(&h) == 0) #define SEARCH(h, n, c, t, a, l) res_nsearch(&h, n, c, t, a, l) -#define PRIMARY_DOMAIN(h) strdup(h.dnsrch[0]) +#define PRIMARY_DOMAIN(h) ((h.dnsrch[0] == NULL) ? NULL : strdup(h.dnsrch[0])) #if HAVE_RES_NDESTROY #define DESTROY_HANDLE(h) res_ndestroy(&h) #else @@ -104,7 +104,8 @@ static int initparse(struct krb5int_dns_state *); #define DECLARE_HANDLE(h) #define INIT_HANDLE(h) (res_init() == 0) #define SEARCH(h, n, c, t, a, l) res_search(n, c, t, a, l) -#define PRIMARY_DOMAIN(h) strdup(_res.defdname) +#define PRIMARY_DOMAIN(h) \ + ((_res.defdname == NULL) ? NULL : strdup(_res.defdname)) #define DESTROY_HANDLE(h) #endif e12376839aa'>treecommitdiff
path: root/etc/openrc
='/guix/commit/etc/completion/bash?id=fa0dc1229c0dc44a7358d183e54d9e02d1199e39'>bash_completion: Complete options for ‘guix environment’....
AgeCommit message (Expand)Author
2020-09-17guix-install.sh: Support OpenRC....Morgan Smith
Tobias Geerinckx-Rice
2021-06-16bash completion: Complete options for the right command....Tobias Geerinckx-Rice
2021-06-16bash completion: Really support subcommands....Tobias Geerinckx-Rice
2020-12-04bash completion: Complete file names after '-f' and '-l'....Ludovic Courtès
2020-09-24bash completion: Adjust to new 'guix help' output....Ludovic Courtès
2020-09-21bash completion: Complete file names after 'guix package -p'....Fulbert
2020-09-10bash completion: Restore completion for 'guix system', etc....Ludovic Courtès
2020-06-27bash completion: Complete 'guix environment' properly....Ludovic Courtès
2020-06-04bash completion: Complete sub-commands after 'guix time-machine'....Ludovic Courtès
2020-06-04bash completion: Complete file names after '-p' and '-C'....Ludovic Courtès
2020-02-14guix build: Add '--manifest' option....Marius Bakke
2019-04-29guix package: Add 'install', 'remove', and 'upgrade' aliases....Ludovic Courtès
2018-11-06bash completion: Restore completion of available packages for 'guix build'....Ludovic Courtès