Fix the early context initialization code to avoid assuming that arguments will be evaluated from right to left. Patch by Mark H Weaver . --- src/lib/krb5/krb/t_cc_config.c.orig 2012-12-17 21:47:05.000000000 -0500 +++ src/lib/krb5/krb/t_cc_config.c 2013-10-29 18:19:16.547994590 -0400 @@ -117,8 +117,8 @@ int c; unsigned int i; - bail_on_err(context, "Error initializing Kerberos library", - krb5_init_context(&context)); + ret = krb5_init_context(&context); + bail_on_err(context, "Error initializing Kerberos library", ret); bail_on_err(context, "Error getting location of default ccache", krb5_cc_default(context, &ccache)); server = NULL; m.submit();'> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/samba.scm
AgeCommit message (Expand)Author
2021-08-04gnu: ldb: Update to 2.4.0....Efraim Flashner
2021-08-04gnu: talloc: Update to 2.3.3....Efraim Flashner
2021-08-04gnu: samba: Update to 4.13.10....Efraim Flashner
2021-08-04gnu: tevent: Update to 0.11.0....Efraim Flashner
2021-04-18gnu: cifs-utils: Update to 6.13....Tobias Geerinckx-Rice
2021-03-06gnu: Fix input typoes....Tobias Geerinckx-Rice
2021-02-07gnu: samba: Update to 4.13.4....Tobias Geerinckx-Rice
2021-02-07gnu: talloc: Update to 2.3.2....Tobias Geerinckx-Rice