Modifications from the internal fork of the python-pytorch package.
diff --git a/miniz.h b/miniz.h
index 42e1ea2..5869ab9 100644
--- a/miniz.h
+++ b/miniz.h
@@ -123,7 +123,7 @@
/* If MINIZ_NO_TIME is specified then the ZIP archive functions will not be able to get the current time, or */
/* get/set file times, and the C run-time funcs that get/set times won't be called. */
/* The current downside is the times written to your archives will be from 1979. */
-/*#define MINIZ_NO_TIME */
+#define MINIZ_NO_TIME
/* Define MINIZ_NO_ARCHIVE_APIS to disable all ZIP archive API's. */
/*#define MINIZ_NO_ARCHIVE_APIS */
@@ -135,7 +135,7 @@
/*#define MINIZ_NO_ZLIB_APIS */
/* Define MINIZ_NO_ZLIB_COMPATIBLE_NAME to disable zlib names, to prevent conflicts against stock zlib. */
-/*#define MINIZ_NO_ZLIB_COMPATIBLE_NAMES */
+#define MINIZ_NO_ZLIB_COMPATIBLE_NAMES
/* Define MINIZ_NO_MALLOC to disable all calls to malloc, free, and realloc.
Note if MINIZ_NO_MALLOC is defined then the user must always provide custom user alloc/free/realloc
@@ -172,8 +172,7 @@
#if !defined(MINIZ_USE_UNALIGNED_LOADS_AND_STORES)
#if MINIZ_X86_OR_X64_CPU
/* Set MINIZ_USE_UNALIGNED_LOADS_AND_STORES to 1 on CPU's that permit efficient integer loads and stores from unaligned addresses. */
-#define MINIZ_USE_UNALIGNED_LOADS_AND_STORES 1
-#define MINIZ_UNALIGNED_USE_MEMCPY
+#define MINIZ_USE_UNALIGNED_LOADS_AND_STORES 0
#else
#define MINIZ_USE_UNALIGNED_LOADS_AND_STORES 0
#endif
diff --git a/miniz_zip.h b/miniz_zip.h
index 82502bd..3d92255 100644
--- a/miniz_zip.h
+++ b/miniz_zip.h
@@ -150,7 +150,7 @@ typedef enum {
MZ_ZIP_TOTAL_ERRORS
} mz_zip_error;
-typedef struct
+typedef struct mz_zip_archive
{
mz_uint64 m_archive_size;
mz_uint64 m_central_directory_file_ofs;
ption>
gnu: maven: Update to 3.9.0....* gnu/packages/maven.scm (maven-pom): Update to 3.9.0.
Change-Id: If6f9f0adf3065b450d373e0fcc619b79e4a529dc
Julien Lepiller
2024-04-20
gnu: maven-resolver-api: Update to 1.9.4....* gnu/packages/maven.scm (maven-resolver-api): Update to 1.9.4.
(maven-resolver-util)[native-inputs]: Update test dependencies.
(maven-resolver-named-lock): New variable.
(maven-resolver-impl, maven-resolver-transport-wagon)
(maven-resolver-transport-http): Update sisu.
Change-Id: I080136e77454ee256a74fff263301e250a2918cb
Julien Lepiller
2024-04-20
gnu: java-guava: Update to 31.1....* gnu/packages/patches/java-guava-remove-annotation-deps.patch: New
file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/java.scm (java-guava): Update to 31.1.
[source]: Use patch.
(java-guava-futures-failureaccess): New variable.
* gnu/packages/bioinformatics.scm (java-picard, java-picard-2.10.3): Fix for
newer guava.
* gnu/packages/maven.scm (maven): Add java-guava-futures-failureaccess.
Change-Id: Id2553c48e11c6001fb45a0589720cef1551804d9
Julien Lepiller
2024-04-20
gnu: java-cglib: Update to 3.3.0....cglib now requires asm-8 at runtime, so propagate it and do not use
asm-6 in dependents.
* gnu/packages/java.scm (java-cglib): Update to 3.3.0.
(java-plexus-component-metadata-1.7, java-easymock, java-jmock)
(java-jmock-legacy, java-jmock-junit4, java-ops4j-pax-exam-core-spi)
(java-guice, java-fest-assert, java-testng, java-lmax-disruptor)
(java-powermock-reflect, java-powermock-modules-junit4)
(java-kafka-clients, java-jline-2, java-xmlunit, java-eclipse-sisu-plexus)
(java-logback-core): Remove `java-asm` from inputs or native-inputs.
(java-httpcomponents-httpclient-cache)
(java-httpcomponents-httpclient-osgi): Disable tests.
* gnu/packages/batik.scm (java-xmlgraphics-commons): Remove `java-asm`
from inputs or native inputs.
* gnu/packages/maven.scm (maven-resolver-transport-file)
(maven-resolver-transport-http, maven-model, maven-repository-metadata)
(maven-compat): Remove `java-asm` from inputs or native-inputs.
Change-Id: I92a939e7522d92b185715d7935aabed5ddb77451