Avoid the default dynamic executable, which depends on minisat.so
Instead install the release version, which is statically linked.
diff --git a/Makefile b/Makefile
index ceb9d77..7b91906 100644
--- a/Makefile
+++ b/Makefile
@@ -191,9 +191,9 @@ install-lib: $(BUILD_DIR)/release/lib/$(MINISAT_SLIB) $(BUILD_DIR)/dynamic/lib/$
ln -sf $(MINISAT_DLIB).$(SOMAJOR) $(DESTDIR)$(libdir)/$(MINISAT_DLIB)
$(INSTALL) -m 644 $(BUILD_DIR)/release/lib/$(MINISAT_SLIB) $(DESTDIR)$(libdir)
-install-bin: $(BUILD_DIR)/dynamic/bin/$(MINISAT)
+install-bin: $(BUILD_DIR)/release/bin/$(MINISAT)
$(INSTALL) -d $(DESTDIR)$(bindir)
- $(INSTALL) -m 755 $(BUILD_DIR)/dynamic/bin/$(MINISAT) $(DESTDIR)$(bindir)
+ $(INSTALL) -m 755 $(BUILD_DIR)/release/bin/$(MINISAT) $(DESTDIR)$(bindir)
clean:
rm -f $(foreach t, release debug profile dynamic, $(foreach o, $(SRCS:.cc=.o), $(BUILD_DIR)/$t/$o)) \
h'/>
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2023-12-10 | bash completion: Complete ‘guix style -f’ with files....* etc/completion/bash/guix (_guix_is_dash_f):
Recognise ‘--whole-file’ as a member of the ‘-f’ family.
(_guix_complete): Add a new clause for ‘guix style’.
Reported by cmiller in #guix.
Change-Id: I3f55f7fd7fb8610dc13770ebfe70d9f65c1497af
| Tobias Geerinckx-Rice |
2023-11-07 | fish completion: Fix typos....* etc/completion/fish/guix.fish (__fish_guix_needs_command): Fix
spelling of specified.
(__fish_guix_using_command): Fix spelling of specified.
Change-Id: Ieac612da8cd2a7a1c44c5a54c57574ce2b8d8bd4
| Efraim Flashner |