Avoid the default dynamic executable, which depends on minisat.so Instead install the release version, which is statically linked. diff --git a/Makefile b/Makefile index ceb9d77..7b91906 100644 --- a/Makefile +++ b/Makefile @@ -191,9 +191,9 @@ install-lib: $(BUILD_DIR)/release/lib/$(MINISAT_SLIB) $(BUILD_DIR)/dynamic/lib/$ ln -sf $(MINISAT_DLIB).$(SOMAJOR) $(DESTDIR)$(libdir)/$(MINISAT_DLIB) $(INSTALL) -m 644 $(BUILD_DIR)/release/lib/$(MINISAT_SLIB) $(DESTDIR)$(libdir) -install-bin: $(BUILD_DIR)/dynamic/bin/$(MINISAT) +install-bin: $(BUILD_DIR)/release/bin/$(MINISAT) $(INSTALL) -d $(DESTDIR)$(bindir) - $(INSTALL) -m 755 $(BUILD_DIR)/dynamic/bin/$(MINISAT) $(DESTDIR)$(bindir) + $(INSTALL) -m 755 $(BUILD_DIR)/release/bin/$(MINISAT) $(DESTDIR)$(bindir) clean: rm -f $(foreach t, release debug profile dynamic, $(foreach o, $(SRCS:.cc=.o), $(BUILD_DIR)/$t/$o)) \ s Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/sdl-libx11-1.6.patch
e source tree by "indent-code.el".
AgeCommit message (Expand)Author
Alex Kost
* etc/indent-code.el.in: Set default directory by "indent-code.el" itself, otherwise it works only when called from the top directory of the guix source tree.
2017-01-20etc: indent-code.el: Add indentation info for non-Guix Scheme constructs.Ludovic Courtès
* etc/indent-code.el.in (guix-syntax--scheme-indent): New macro. Use it.
2017-01-13etc: Support indentation of whole files.Ludovic Courtès
* etc/indent-package.el.in: Rename to... * etc/indent-code.el.in: ... this. Add case for a single argument. * doc/contributing.texi (Formatting Code): Adjust accordingly. * configure.ac: Likewise.