The VTK_MAJOR_VERSION macro is not available by default in newer versions. This is a hack to expose it without changing all imports. diff --git a/addons/vtk/CMakeLists.txt b/addons/vtk/CMakeLists.txt --- a/addons/vtk/CMakeLists.txt +++ b/addons/vtk/CMakeLists.txt @@ -36,6 +36,8 @@ IF(WITH_VTKIO) ELSE() SET(SELECTED_VTK_LIBS ${VTK_MODULES_REQUESTED}) ENDIF() + + add_compile_definitions(VTK_MAJOR_VERSION=${VTK_VERSION_MAJOR}) SET(VTK_LINK_LIBS_MESH ${SELECTED_VTK_LIBS} miamesh) SET(VTK_LINK_LIBS_3D ${SELECTED_VTK_LIBS} mia3d) a>
Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/system/shadow.scm
AgeCommit message (Expand)Author
2023-10-06system: Modify bash skeleton to colorize 'ip' output....* gnu/system/shadow.scm (%default-bashrc): Add an alias for 'ip' that enables output colorization. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Bruno Victal
2023-06-09system: account: Fix default value....Fixes a regression introduced in 66ecffbeba0685ff2f1071db8aeb2393986afb97. * gnu/system/shadow.scm (account-service-type)[default-value]: Change to the empty list. Ludovic Courtès
2023-05-16services: Add default values....* gnu/services.scm (boot-service-type, activation-service-type, etc-service-type, profile-service-type): Add default-value. * gnu/system/shadow.scm (account-service-type): Add default-value. Andrew Tropin
2023-05-12system: default-skeletons: Merge search-paths of multiple profiles....Fixes <https://issues.guix.gnu.org/20255>. * gnu/system/shadow.scm (default-skeletons)[bash_profile, zprofile]: Merge search-paths from multiple profiles via "guix package". 宋文武
2023-03-07system: Update skeleton gdbinit....* gnu/system/shadow.scm (default-skeleton): Update gdbinit to search for more debug packages in guix-home and the system profile. (skeleton-directory): Move .gdbinit to .config/gdb/gdbinit. Efraim Flashner
2023-02-08system: Source .profile in skeleton bash_profile....Make it consistent with bash_profile generated by Guix Home. * gnu/system/shadow.scm (default-skeletons)[bash_profile]: Source .profile in skeleton bash_profile. Andrew Tropin
2023-01-05system: Define default 'PS1' in /etc/bashrc rather than ~/.bashrc....Users can override 'PS1' in ~/.bashrc if they wish. Previously, on Guix Home, the "default" 'PS1' would be set in ~/.bashrc when 'home-bash-configuration-guix-defaults?' is true, preventing users from overriding it via the 'environment-variables' field of 'home-bash-extension'. * gnu/system/shadow.scm (%default-bashrc): Remove 'PS1' setting. * gnu/system.scm (operating-system-etc-service): Define PS1 in /etc/bashrc. * gnu/home/services/shells.scm (add-bash-configuration): When 'home-bash-configuration-guix-defaults?' is true, add a default 'PS1' to ~/.bash_profile. Ludovic Courtès
2023-01-05system, home: Factorize default '.bashrc'....* gnu/system/shadow.scm (%default-bashrc): New variable. Source /etc/bashrc only if it exists. (default-skeletons): Use it. * gnu/home/services/shells.scm (guix-bashrc): Remove. (add-bash-configuration): Refer to '%default-bashrc' instead. Ludovic Courtès