This patch from resolution of https://sourceforge.net/p/mhash/bugs/37/ --- a/src/keygen_test.c +++ b/src/keygen_test.c @@ -121,8 +121,6 @@ mhash_keygen_ext(KEYGEN_S2K_SALTED, data, key, keysize, password, passlen); - mutils_memset(tmp, 0, keysize * 2); - tmp = mutils_asciify(key, keysize); result = mutils_strcmp((mutils_word8 *) KEY2, tmp); cgit logo index : guix
Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/services/herd.scm
AgeCommit message (Expand)Author
2020-03-03services: herd: Add restart-service....* gnu/services/herd.scm (restart-service): New exported procedure. Mathieu Othacehe
2019-10-18herd: Define 'shepherd-message-port'....* gnu/services/herd.scm (shepherd-message-port): New variable. (display-message): Use it instead of 'current-error-port'. Ludovic Courtès
2019-07-26guix system: Add 'reconfigure' module....* guix/scripts/system/reconfigure.scm: New file. * Makefile.am (MODULES): Add it. * guix/scripts/system.scm (bootloader-installer-script): Export variable. * gnu/machine/ssh.scm (switch-to-system, upgrade-shepherd-services) (install-bootloader): Delete variable. * gnu/machine/ssh.scm (deploy-managed-host): Rewrite procedure. * gnu/services/herd.scm (live-service): Export variable. * gnu/services/herd.scm (live-service-canonical-name): New variable. * tests/services.scm (live-service): Delete variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Jakob L. Kreuze
2019-06-02herd: Use the Guile 2.2 'setvbuf' API....* gnu/services/herd.scm (open-connection): Use 'block for 'setvbuf'. Ludovic Courtès
2019-01-17services: herd: Allow to pass arguments to start-service....* gnu/services/herd.scm (start-service)[arguments]: New optional argument. Mathieu Othacehe
2018-09-26guix system: Load all services on reconfigure, not just stopped ones....This uses the 'replacement' service slot introduced in the Shepherd version 0.5.0. * gnu/services/shepherd.scm (shepherd-service-upgrade): Return a list of services that need to be restarted to complete their upgrade. * guix/scripts/system.scm (call-with-service-upgrade-info): Rename an internal variable to reflect the change to shepherd-service-upgrade. (upgrade-shepherd-services): Call 'load-services/safe' instead of 'load-services'. Print a message about services that need to be manually restarted. * gnu/services/herd.scm (load-services/safe): New procedure. * doc/guix.texi (Invoking guix system): Document the new behaviour. Co-authored-by: Ludovic Courtès <ludo@gnu.org> Carlo Zancanaro
2018-07-13services: mcron: Add 'schedule' action....Inspired by <https://lists.gnu.org/archive/html/help-guix/2018-07/msg00035.html>. * gnu/services/mcron.scm (shepherd-schedule-action): New procedure. (mcron-shepherd-services): Add 'actions' field. * gnu/tests/base.scm (run-mcron-test)["schedule action"]: New test. * doc/guix.texi (Scheduled Job Execution): Mention 'herd schedule'. Ludovic Courtès
2018-01-21services: herd: 'with-shepherd' no longer leaves an open connection....* gnu/services/herd.scm (with-shepherd): Use 'dynamic-wind' and close CONNECTION at the end. Ludovic Courtès