disk_cache_create() here looks up the users home directory from which resolves to "/" in the build environment. I could not find an easy way to set the home directory to something else, so we disable this test for now. --- a/src/compiler/glsl/tests/cache_test.c +++ b/src/compiler/glsl/tests/cache_test.c @@ -170,11 +170,6 @@ unsetenv("MESA_GLSL_CACHE_DIR"); unsetenv("XDG_CACHE_HOME"); - cache = disk_cache_create("test", "make_check", 0); - expect_non_null(cache, "disk_cache_create with no environment variables"); - - disk_cache_destroy(cache); - /* Test with XDG_CACHE_HOME set */ setenv("XDG_CACHE_HOME", CACHE_TEST_TMP "/xdg-cache-home", 1); cache = disk_cache_create("test", "make_check", 0); n value='koszko' selected='selected'>koszko Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/build/linux-modules.scm
AgeCommit message (Expand)Author
2019-08-16linux-modules: Define and use a module name database....Ludovic Courtès
2019-08-16linux-modules: Add 'load-linux-modules-from-directory'....Ludovic Courtès
2019-08-16linux-modules: Add "modules.devname" writer....Ludovic Courtès
2019-08-16linux-modules: Add "modules.alias" writer....Danny Milosavljevic
2019-03-13linux-modules: Factorize 'missing-modules'....Ludovic Courtès
2019-03-05linux-modules: module-soft-dependencies: Partition the result and return it a......Danny Milosavljevic
2019-01-25linux-modules: module-soft-dependencies: Remove colon from section names....Danny Milosavljevic
2019-01-25linux-modules: Add module-soft-dependencies....Danny Milosavljevic