diff --git a/mcrypt-CVE-2012-4426.patch b/mcrypt-CVE-2012-4426.patch
new file mode 100644
index 0000000..747f428
--- mcrypt-2.6.8/src/errors.c
+++ mcrypt-2.6.8/src/errors.c
@@ -25,24 +25,24 @@
void err_quit(char *errmsg)
{
- fprintf(stderr, errmsg);
+ fprintf(stderr, "%s", errmsg);
exit(-1);
}
void err_warn(char *errmsg)
{
if (quiet <= 1)
- fprintf(stderr, errmsg);
+ fprintf(stderr, "%s", errmsg);
}
void err_info(char *errmsg)
{
if (quiet == 0)
- fprintf(stderr, errmsg);
+ fprintf(stderr, "%s", errmsg);
}
void err_crit(char *errmsg)
{
if (quiet <= 2)
- fprintf(stderr, errmsg);
+ fprintf(stderr, "%s", errmsg);
}
---
f3d90d99b4634447b72e355ff0'/>
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2022-01-09 | nls: Update translations....* po/doc/guix-cookbook.fi.po: New file.
* po/doc/guix-manual.fi.po: New file.
* po/doc/local.mk: Add them.
* doc/local.mk: Add them.
* po/guix/fi.po: New file.
* po/guix/LINGUAS: Add it.
| Julien Lepiller |
2021-12-04 | nls: Update translations. | Julien Lepiller |
2021-11-06 | nls: Update translations....* po/doc/guix-cookbook.es.po: New file.
* po/doc/local.mk: Add 'es' cookbook.
* doc/local.mk: Add 'es' cookbook.
| Julien Lepiller |
2021-10-17 | nls: Update translations. | Julien Lepiller |
2021-09-02 | nls: Update translations....* po/packages/it.po: New file.
* po/packages/LINGUAS: Add `it'.
* po/*/*.po: Update translations.
| Julien Lepiller |
2021-08-04 | nls: Update translations....* po/doc/guix-cookbook.ru.po: New file.
* po/doc/guix-cookbook.sk.po: New file.
* po/*/*.po: Update translations.
* doc/local.mk (COOKBOOK_LANGUAGES): Add ru and sk.
(info_TEXINFOS): Add Russian and Slovak cookbooks.
* po/doc/local.mk (DOC_COOKBOOK_PO_FILES): Add Russian and Slovak po
files.
| Julien Lepiller |
2021-05-10 | nls: Update translations. | Maxim Cournoyer |
2021-04-18 | nls: Update 'ru' translation. | Julien Lepiller |