From 4876e3a692739bb9ca00d0f500fd5f4b3eb16ce3 Mon Sep 17 00:00:00 2001 From: Tom Callaway Date: Fri, 7 Sep 2012 11:39:29 -0400 Subject: apply fix for CVE-2012-4409 (thanks to Raphael Geissert) --- mcrypt-2.6.8/src/extra.c.CVE-2012-4409 2012-09-07 11:00:55.906870746 -0400 +++ mcrypt-2.6.8/src/extra.c 2012-09-07 11:00:27.967858365 -0400 @@ -242,6 +242,8 @@ int check_file_head(FILE * fstream, char if (m_getbit(0, sflag) != 0) { /* if the first bit is set */ *salt_size = m_setbit(0, sflag, 0); if (*salt_size > 0) { + if (*salt_size > sizeof(tmp_buf)) + err_quit(_("Salt is too long\n")); fread(tmp_buf, 1, *salt_size, fstream); memmove(salt, tmp_buf, *salt_size); -- cgit v0.12 ed='selected'>koszko Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/services/vpn.scm
AgeCommit message (Expand)Author
2023-09-09services: vpn: Fix broken format string for wireguard dns....Reily Siegel
2023-07-21services: wireguard: Add a 'configuration' action....Maxim Cournoyer
2023-07-21services: wireguard: Clean-up configuration file serializer....Maxim Cournoyer
2023-07-21services: wireguard: Implement a dynamic IP monitoring feature....Maxim Cournoyer
2023-03-03services: vpn: Deprecate 'openvpn-client-service' & 'openvpn-server-service' ......Bruno Victal
2022-12-25services: wireguard: Allow specifying pre-shared keys....Timo Wilken
2022-12-09services: wireguard: Use the parameterized wireguard package....EuAndreh
2022-11-13services: vpn: Fix the profile wireguard package....EuAndreh
2022-11-12services: vpn: Add wireguard-tools to profile-service-type....EuAndreh
2022-10-20services: wireguard: Add more configuration fields....Mathieu Othacehe
2022-06-24services: configuration: Remove 'validate-configuration'....Ludovic Courtès
2022-06-22services: wireguard: Shepherd 'stop' method really stops....Ludovic Courtès
2022-06-15services: configuration: Use *unspecified* instead of 'disabled....Attila Lendvai
2022-04-29services: Add missing 'description' fields....Ludovic Courtès
2022-03-03services: openvpn: Actually save log file....Cameron Chaparro