This patch allows us to install the Vixie-compatible binaries as
non-root without creating /var/run, etc.
--- mcron-1.0.6/makefile.in 2010-06-19 20:44:17.000000000 +0200
+++ mcron-1.0.6/makefile.in 2010-07-04 16:16:25.000000000 +0200
@@ -1004,15 +1004,11 @@ mcron.c : main.scm crontab.scm makefile.
@rm -f mcron.escaped.scm > /dev/null 2>&1
install-exec-hook:
- @if [ "x@NO_VIXIE_CLOBBER@" != "xyes" -a "`id -u`" -eq "0" ]; then \
+ @if [ "x@NO_VIXIE_CLOBBER@" != "xyes" ]; then \
rm -f $(fpp)cron$(EXEEXT) > /dev/null 2>&1; \
$(INSTALL) --mode='u=rwx' mcron$(EXEEXT) $(fpp)cron$(EXEEXT); \
rm -f $(fpp)crontab$(EXEEXT) > /dev/null 2>&1; \
$(INSTALL) --mode='u=rwxs,og=rx' mcron$(EXEEXT) $(fpp)crontab$(EXEEXT); \
- $(INSTALL) -d --mode='u=rwx' $(DESTDIR)/var/cron; \
- $(INSTALL) -d --mode='u=rwx,og=rx' $(DESTDIR)/var/run; \
- $(INSTALL) -d --mode='u=rwx,og=rx' $(DESTDIR)@GUILE_SITE@; \
- $(INSTALL) -d --mode='u=rwx,og=rx' $(DESTDIR)@GUILE_SITE@/mcron; \
elif [ "x@NO_VIXIE_CLOBBER@" = "xyes" ]; then \
echo "Not installing Vixie-style programs"; \
else \
214c889322b78a54db23135a06731bc6d'>refslogtreecommitdiff
|
Age | Commit message (Expand) | Author |
2023-03-16 | home: services: kodi, znc, ssh-agent: Use 'match-record'....* gnu/home/services/media.scm (home-kodi-services): Use 'match-record'
instead of 'match'.
* gnu/home/services/messaging.scm (home-znc-services): Likewise.
* gnu/home/services/ssh.scm (home-ssh-agent-services): Likewise.
| Ludovic Courtès |
2023-03-16 | home: services: kodi: Remove host-side use of (shepherd support)....This is a followup to 70056b1b2beebbc9f8ea2c34eacc57f379368ab3, which
inadvertently pulled in (shepherd support) on the host side.
* gnu/home/services/media.scm (home-kodi-services): Change 'command' and
'logfile' to gexps. Add 'modules' field to 'shepherd-service'.
| Ludovic Courtès |
2023-03-16 | gnu: home: services: Add home-kodi-service-type....* gnu/home/services/media.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
* po/guix/POTFILES.in: Likewise.
* doc/guix.texi (Media Home Services): Document it in new subsection.
| Jan (janneke) Nieuwenhuizen |