Change 'ensure-directories-exist' to look for 'mkdir' in $PATH, not in /bin. --- maxima-5.36.1/lisp-utils/defsystem.lisp.orig 2014-11-22 16:21:30.000000000 -0500 +++ maxima-5.36.1/lisp-utils/defsystem.lisp 2015-05-25 21:53:31.223648483 -0400 @@ -4627,7 +4627,7 @@ (cmd (if (member :win32 *features*) (format nil "mkdir \"~a\"" (coerce (subst #\\ #\/ (coerce (namestring dir) 'list)) 'string)) - (format nil "/bin/mkdir -p ~S" (namestring dir))))) + (format nil "mkdir -p ~S" (namestring dir))))) (unless (directory dir) (lisp:system cmd)) ;; The second return value is supposed to be T if directories were .form.submit();'> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ntp.scm
AgeCommit message (Expand)Author
2020-12-13gnu: openntpd: Update to 6.8p1....* gnu/packages/ntp.scm (openntpd): Update to 6.8p1. Tobias Geerinckx-Rice
2020-10-13gnu: libcap: Make 'libcap/next' the default libcap....* gnu/packages/avahi.scm (avahi)[inputs]: Refer to LIBCAP-2.31 instead of LIBCAP. * gnu/packages/base.scm (coreutils)[inputs]: Likewise. * gnu/packages/linux.scm (libcap): Rename to ... (libcap-2.31): ... this. (libcap/next): Rename to ... (libcap): ... this. (libcap/next): Define as deprecated alias for LIBCAP. (fakeroot)[inputs]: Change from LIBCAP/NEXT to LIBCAP. * gnu/packages/ntp.scm (chrony, ntp)[inputs]: Likewise. Marius Bakke
2020-10-08gnu: chrony: Support Network Time Security (NTS)....* gnu/packages/ntp.scm (chrony)[inputs]: Add gnutls. Tobias Geerinckx-Rice
2020-10-08gnu: chrony: Update to 4.0....* gnu/packages/ntp.scm (chrony): Update to 4.0. Tobias Geerinckx-Rice
2020-09-13gnu: Fix a crash in NTP and Chrony....Fixes <https://bugs.gnu.org/43321>. * gnu/packages/ntp.scm (ntp, chrony)[inputs]: Replace libcap with libcap/next. Leo Famulari
2020-08-20gnu: chrony: Update to 3.5.1 [fixes CVE-2020-14367]....* gnu/packages/ntp.scm (chrony): Update to 3.5.1. Tobias Geerinckx-Rice
2020-07-11gnu: ntp: Update to 4.2.8p15 [security fixes]....* gnu/packages/ntp.scm (ntp): Update to 4.2.8p15. [source]: Swap order of URIs. Tobias Geerinckx-Rice
2020-04-08gnu: openntpd: Don't use NAME in source URI....* gnu/packages/ntp.scm (openntpd)[source]: Hard-code NAME. Tobias Geerinckx-Rice
2020-04-08gnu: Add chrony....* gnu/packages/ntp.scm (chrony): New public variable. Tobias Geerinckx-Rice
2020-03-31gnu: Order module imports in (gnu packages ntp)....This shouldn't cause any conflicts :-) * gnu/packages/ntp.scm: Order module imports alphabetically. Tobias Geerinckx-Rice