From 1d20c0e403f1a38d4aca830e0eb4db03ba43efd3 Mon Sep 17 00:00:00 2001 From: Julien Lepiller Date: Tue, 19 Sep 2017 22:21:29 +0200 Subject: [PATCH] Add sisu-maven-plugin replacement --- sisu.sh | 12 ++++++++++++ 1 file changed, 12 insertions(+) create mode 100755 sisu.sh diff --git a/sisu.sh b/sisu.sh new file mode 100755 index 0000000..979f373 --- /dev/null +++ b/sisu.sh @@ -0,0 +1,12 @@ +## This script generates a rough javax.inject.Named file. It is meant to +## replace sisu-maven-plugin as it eventually has a recursive dependency +## on maven. +## +## This script must be run in the source directory (usually src/main/java). + +for file in `(cd $1; find -name '*.java')`; do + annot=`grep "^@Named" $1/$file` + if [ "$annot" != "" ]; then + echo $file | sed -e 's|^\./||' -e 's|\.java||' -e 's|/|.|g' + fi +done > $2 -- 2.14.1 form> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/tests/telephony.scm
AgeCommit message (Expand)Author
2024-01-09tests: telephony: Fix typo....Maxim Cournoyer
2024-01-09tests: telephony: Fix VPATH builds....Wojtek Kosior
2023-12-22tests: jami: Double timeouts....Ludovic Courtès
2023-12-22tests: jami: Check status of Jami D-Bus session....Ludovic Courtès
2023-05-25tests: Fix the Jami service system tests....Maxim Cournoyer
2023-05-06tests: Add missing module imports for marionette-evaluated code....Ludovic Courtès
2022-09-26tests: telephony: Add missing import to fix jami tests....Maxim Cournoyer
2022-09-24Revert "tests: telephony: Add extra packages to %jami-os for debugging."...Maxim Cournoyer
2022-09-23tests: jami-provisioning: Fix test derivation name....Maxim Cournoyer
2022-09-23tests: telephony: Add extra packages to %jami-os for debugging....Maxim Cournoyer
2022-08-01gnu: telephony: Add a Jami test for a partially defined jami-account....Maxim Cournoyer
2022-06-10services: jami: Modernize to adjust to Shepherd 0.9+ changes....Maxim Cournoyer
2022-01-13services: Adjust the jami service for the upgraded jami....Maxim Cournoyer