Remove dependencies on xwin and zig. We're not offering cross-compilation
options using these crates.
diff --git a/Cargo.toml b/Cargo.toml
index 6704e46..ff126a9 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -83,16 +83,6 @@ version = "0.1.16"
[dependencies.cargo-options]
version = "0.7.2"
-[dependencies.cargo-xwin]
-version = "0.16.2"
-optional = true
-default-features = false
-
-[dependencies.cargo-zigbuild]
-version = "0.18.0"
-optional = true
-default-features = false
-
[dependencies.cargo_metadata]
version = "0.18.0"
@@ -321,8 +311,6 @@ version = "5.0.0"
[features]
cli-completion = ["dep:clap_complete_command"]
cross-compile = [
- "zig",
- "xwin",
]
default = [
"full",
@@ -341,7 +329,6 @@ log = ["tracing-subscriber"]
native-tls = [
"dep:native-tls",
"ureq?/native-tls",
- "cargo-xwin?/native-tls",
"dep:rustls-pemfile",
]
password-storage = [
@@ -351,7 +338,6 @@ password-storage = [
rustls = [
"dep:rustls",
"ureq?/tls",
- "cargo-xwin?/rustls-tls",
"dep:rustls-pemfile",
]
scaffolding = [
@@ -369,5 +355,3 @@ upload = [
"wild",
"dep:dirs",
]
-xwin = ["cargo-xwin"]
-zig = ["cargo-zigbuild"]
href='/guix/log/tests/build-emacs-utils.scm'>logtreecommitdiff
|
Age | Commit message (Expand) | Author |
2022-07-13 | tests: build-emacs-utils: Allow test to pass on Emacs 27 too....* tests/build-emacs-utils.scm
("emacs-batch-script: raise &emacs-batch-error on failure"): More loosely
match expected error string, which differs between Emacs 27 and Emacs 28.
| Maxim Cournoyer |
2022-06-17 | guix: emacs-utils: Add emacs-header-parse....* guix/build/emacs-utils.scm (emacs-header-parse): New procedure.
* tests/build-emacs-utils.scm ("emacs-header-parse: fetch version",
"emacs-header-parse: fetch keywords", "emacs-header-parse: fetch
nonexistent author"): New tests.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Fredrik Salomonsson |
2022-06-17 | guix: emacs-utils: Add emacs-batch-script....* guix/build/emacs-utils.scm (emacs-batch-script): New procedure.
* tests/build-emacs-utils.scm: New file.
* Makefile.am (TESTS): Add `tests/build-emacs-utils.scm'.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Fredrik Salomonsson |