Remove dependencies on xwin and zig. We're not offering cross-compilation
options using these crates.
diff --git a/Cargo.toml b/Cargo.toml
index 6704e46..ff126a9 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -83,16 +83,6 @@ version = "0.1.16"
[dependencies.cargo-options]
version = "0.7.2"
-[dependencies.cargo-xwin]
-version = "0.16.2"
-optional = true
-default-features = false
-
-[dependencies.cargo-zigbuild]
-version = "0.18.0"
-optional = true
-default-features = false
-
[dependencies.cargo_metadata]
version = "0.18.0"
@@ -321,8 +311,6 @@ version = "5.0.0"
[features]
cli-completion = ["dep:clap_complete_command"]
cross-compile = [
- "zig",
- "xwin",
]
default = [
"full",
@@ -341,7 +329,6 @@ log = ["tracing-subscriber"]
native-tls = [
"dep:native-tls",
"ureq?/native-tls",
- "cargo-xwin?/native-tls",
"dep:rustls-pemfile",
]
password-storage = [
@@ -351,7 +338,6 @@ password-storage = [
rustls = [
"dep:rustls",
"ureq?/tls",
- "cargo-xwin?/rustls-tls",
"dep:rustls-pemfile",
]
scaffolding = [
@@ -369,5 +355,3 @@ upload = [
"wild",
"dep:dirs",
]
-xwin = ["cargo-xwin"]
-zig = ["cargo-zigbuild"]
x/log/gnu/services/sound.scm'>logtreecommitdiff
|
Age | Commit message (Expand) | Author |
2020-05-06 | services: Do not use symbolic links in PulseAudio variables....This addresses <https://bugs.gnu.org/40837> by making these configuration
files more easily accessible within the WebKitGTK sandbox.
* gnu/services/sound.scm (pulseaudio-environment): Move below
PULSEAUDIO-CONF-ENTRY. Instantiate PULSE_CONFIG and PULSE_CLIENTCONFIG
entries directly instead of referring to /etc/pulse.
(pulseaudio-etc): Do not create /etc/pulse/client.conf and /etc/pulse/daemon.conf.
| Marius Bakke |
2020-01-11 | services: Split ladspa-service-type from pulseaudio-service-type....* gnu/services/sound.scm (ladspa-configuration): New record.
(ladspa-environment): New procedure.
(ladspa-service-type): New service type.
(pulseaudio-environment): Remove LADSPA_PATH.
* doc/guix.texi: Adjust documentation.
Signed-off-by: Marius Bakke <mbakke@fastmail.com>
| Leo Prikler |
2020-01-11 | services: pulseaudio-configuration: Set flat-volumes to no....* gnu/services/sound (pulseaudio-configuration) [daemon-conf]: Disable
flat-volumes, which causes unpleasant experiences to users when applications
inadvertently max out the system volume (e.g. as in #38172).
Signed-off-by: Marius Bakke <mbakke@fastmail.com>
| Leo Prikler |
2020-01-11 | services: Add pulseaudio-configuration....* gnu/services/sound (<pulseaudio-configuration>): New record.
(pulseaudio-etc): New procedure.
(pulseaudio-environment): Add PULSE_CONFIG and PULSE_CLIENTCONFIG.
(pulseaudio-service-type): Update accordingly.
Signed-off-by: Marius Bakke <mbakke@fastmail.com>
| Leo Prikler |
2020-01-08 | services: Add pulseaudio service....* gnu/services/sound.scm (pulseaudio-environment): New procedure.
(pulseaudio-service-type): New variable.
* doc/guix.texi (Sound Services): Document it.
| Oleg Pykhalov |