Remove install target for non-existant directory.
--- a/src/CMakeLists.txt 2015-09-13 20:52:28.517344327 +0200
+++ b/src/CMakeLists.txt 2015-09-13 20:53:04.842453987 +0200
@@ -122,12 +122,6 @@
DESTINATION
${CMAKE_INSTALL_PREFIX}/share/applications
)
- install(
- FILES
- ${MARS_SOURCE_DIR}/resources/mars
- DESTINATION
- ${CMAKE_INSTALL_PREFIX}/share/menu
- )
else(UNIX)
# executable
>
index : guix | |
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2020-01-12 | daemon: Account for deleted store files when deduplication is on....Previously, a store item that is a regular file would not be accounted
for in the 'bytesFreed' value computed by 'deletePath' because its
'st_nlink' count would always be >= 2. This commit fixes that.
* nix/libutil/util.hh (deletePath): Add optional 'linkThreshold' argument.
* nix/libutil/util.cc (_deletePath): Add 'linkThreshold' argument and
honor it. Pass it down in recursive call.
(deletePath): Add 'linkThreshold' and honor it.
* nix/libstore/gc.cc (LocalStore::deleteGarbage): Pass 'linkThreshold'
argument to 'deletePath', with a value of 2 when PATH is a store item
and deduplication is on.
| Ludovic Courtès |