From 93efa48a7b972fc463406603574a4d508eefe792 Mon Sep 17 00:00:00 2001 From: Sergei Golubchik Date: Sun, 13 May 2018 18:50:21 +0200 Subject: [PATCH] fix failing main.mysql_client_test test on 32bit in `ulonglong=ulong*uint` multiplication is done in ulong, wrapping around on 32bit. This became visible after C/C changed the default charset to utf8, thus changing mbmaxlem from 1 to 3. --- tests/mysql_client_fw.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/tests/mysql_client_fw.c b/tests/mysql_client_fw.c index f69eb28a2871..4d036887629a 100644 --- a/tests/mysql_client_fw.c +++ b/tests/mysql_client_fw.c @@ -768,7 +768,7 @@ static void do_verify_prepare_field(MYSQL_RES *result, { MYSQL_FIELD *field; CHARSET_INFO *cs; - ulonglong expected_field_length; + ulonglong expected_field_length= length; if (!(field= mysql_fetch_field_direct(result, no))) { @@ -777,7 +777,7 @@ static void do_verify_prepare_field(MYSQL_RES *result, } cs= get_charset(field->charsetnr, 0); DIE_UNLESS(cs); - if ((expected_field_length= length * cs->mbmaxlen) > UINT_MAX32) + if ((expected_field_length*= cs->mbmaxlen) > UINT_MAX32) expected_field_length= UINT_MAX32; if (!opt_silent) { s/storage.scm?id=9bb98f6425f2d9bd45a7dd432b2480e5a8cb7306'>treecommitdiff
path: root/gnu/packages/storage.scm
AgeCommit message (Expand)Author
2018-04-30Merge branch 'master' into core-updatesMark H Weaver
2018-04-25gnu: ceph: Update to 12.2.5....Marius Bakke
2018-03-29gnu: cmake: Update to 3.11.0....Marius Bakke
2018-03-15gnu: Remove boost-1.66....Ricardo Wurmus
2018-03-04gnu: ceph: Update to 12.2.4....Marius Bakke
2018-01-19gnu: Consistently Write ‘file system(s)’....Tobias Geerinckx-Rice
2017-12-28gnu: ceph: Disable tests....Rutger Helling
2017-11-17gnu: Move testing packages from python.scm to check.scm....Ricardo Wurmus