Purity: don't look for library dependencies (of the form `-lfoo') in
/lib and /usr/lib. Likewise, when searching for included Makefiles,
don't look in /usr/include and friends.
Patch from Nixpkgs, by Eelco Dolstra.
diff -rc make-3.81-orig/read.c make-3.81/read.c
*** make-3.81-orig/read.c 2006-03-17 15:24:20.000000000 +0100
--- make-3.81/read.c 2007-05-24 17:16:31.000000000 +0200
***************
*** 99,107 ****
--- 99,109 ----
#endif
INCLUDEDIR,
#ifndef _AMIGA
+ #if 0
"/usr/gnu/include",
"/usr/local/include",
"/usr/include",
+ #endif
#endif
0
};
diff -rc make-3.81-orig/remake.c make-3.81/remake.c
*** make-3.81-orig/remake.c 2006-03-20 03:36:37.000000000 +0100
--- make-3.81/remake.c 2007-05-24 17:06:54.000000000 +0200
***************
*** 1452,1460 ****
--- 1452,1462 ----
static char *dirs[] =
{
#ifndef _AMIGA
+ #if 0
"/lib",
"/usr/lib",
#endif
+ #endif
#if defined(WINDOWS32) && !defined(LIBDIR)
/*
* This is completely up to the user at product install time. Just define
/guix/'>summaryrefslogtreecommitdiff
|
Age | Commit message (Expand) | Author |
2021-06-12 | etc: indent-code.el: Remove any existing tabs....* etc/indent-code.el (main): Call UNTABIFY on the sexp or entire buffer.
| Tobias Geerinckx-Rice |
2020-08-18 | etc: indent-code.el: Match not only ‘(define-public’....* etc/indent-code.el (main): Also match ‘(define’, as intended.
| Tobias Geerinckx-Rice |
2020-05-14 | etc: indent-code.el: Use the --quick option....This prevents Emacs from loading the autoload definitions found in its
profile, which needlessly clutters the output. It also prevents Geiser (if
installed) from blocking the script and asking the user to input the Scheme
implementation to use.
The trick for passing multiple arguments to Emacs is to use what is called a
"sesquicolon" (see https://www.emacswiki.org/emacs/EmacsScripts).
* etc/indent-code.el.in: Rename to...
* etc/indent-code.el: ...this. Adapt the shebang to use a sesquicolon, and
pass the --quick option to Emacs. Since this line is interpreted by the
shell, simply use Emacs from the PATH instead of from a hard coded location.
(main): New procedure, used as the entry point.
* configure.ac: Remove the warning about Emacs. Emacs can now be installed
any time by the user if they want to use the script.
* .gitignore: No longer ignore changes to etc/indent-code.el.
| Maxim Cournoyer |