Patch the two Makefile to also create liblua.so Original patch by Allan McRae for Archlinux diff -ruN lua-5.1.5/Makefile lua-5.1.5-new/Makefile --- lua-5.1.5/Makefile 2012-02-10 10:50:23.000000000 +0100 +++ lua-5.1.5-new/Makefile 2014-09-10 20:17:28.913951433 +0200 @@ -43,7 +43,7 @@ # What to install. TO_BIN= lua luac TO_INC= lua.h luaconf.h lualib.h lauxlib.h ../etc/lua.hpp -TO_LIB= liblua.a +TO_LIB= liblua.a liblua.so liblua.so.${V} TO_MAN= lua.1 luac.1 # Lua version and release. @@ -53,7 +53,7 @@ all: $(PLAT) $(PLATS) clean: - cd src && $(MAKE) $@ + cd src && $(MAKE) $@ V=$(V) R=$(R) test: dummy src/lua test/hello.lua diff -ruN lua-5.1.5/src/Makefile lua-5.1.5-new/src/Makefile --- lua-5.1.5/src/Makefile 2012-02-13 21:41:22.000000000 +0100 +++ lua-5.1.5-new/src/Makefile 2014-09-10 20:16:09.982952152 +0200 @@ -8,7 +8,7 @@ PLAT= none CC= gcc -CFLAGS= -O2 -Wall $(MYCFLAGS) +CFLAGS= -O2 -Wall $(MYCFLAGS) -fPIC AR= ar rcu RANLIB= ranlib RM= rm -f @@ -34,9 +34,10 @@ LUAC_T= luac LUAC_O= luac.o print.o +LUA_SO= liblua.so ALL_O= $(CORE_O) $(LIB_O) $(LUA_O) $(LUAC_O) -ALL_T= $(LUA_A) $(LUA_T) $(LUAC_T) +ALL_T= $(LUA_A) $(LUA_T) $(LUAC_T) $(LUA_SO) ALL_A= $(LUA_A) default: $(PLAT) @@ -57,6 +58,13 @@ $(LUAC_T): $(LUAC_O) $(LUA_A) $(CC) -o $@ $(MYLDFLAGS) $(LUAC_O) $(LUA_A) $(LIBS) +$(LUA_SO): $(CORE_O) $(LIB_O) + $(CC) -shared -ldl -Wl,-soname,$(LUA_SO).$(V) -o $@.$(R) $? -lm $(MYLDFLAGS) + ln -sf $(LUA_SO).$(R) $(LUA_SO).$(V) + ln -sf $(LUA_SO).$(R) $(LUA_SO) + + + clean: $(RM) $(ALL_T) $(ALL_O) t name='qt'>
path: root/nix
AgeCommit message (Expand)Author
2024-05-13daemon: Loop over ‘copy_file_range’ upon short writes....Ludovic Courtès
2024-03-12daemon: Address shortcoming in previous security fix for CVE-2024-27297....Ludovic Courtès
2024-03-11daemon: Protect against FD escape when building fixed-output derivations (CVE......Ludovic Courtès
2024-01-05daemon: Change default ‘timeout’ and ‘max-silent-time’ values....Ludovic Courtès
2023-12-17daemon: Fix my own whitespace errors....Tobias Geerinckx-Rice
2023-12-10daemon: Sacrifice builders on OOM....Tobias Geerinckx-Rice
2023-12-11daemon: Implement ‘substitute-urls’ RPC....Ludovic Courtès
2023-12-04daemon: Simplify “empty status” substitute error message....Ludovic Courtès
2023-09-24Revert "build: Add missing guix-gc.timer file to binary tarball."...Tobias Geerinckx-Rice
2023-09-26daemon: Add “git-download” built-in builder....Ludovic Courtès
2023-09-09daemon: Fix build with GCC 13....Sören Tempel
2023-08-31build: Add missing guix-gc.timer file to binary tarball....Maxim Cournoyer
2023-01-09daemon: Improve error message for wrong hash sizes....Ludovic Courtès