From: Enrico Tassi Date: Tue, 26 Aug 2014 16:20:55 +0200 Subject: Fix stack overflow in vararg functions --- src/ldo.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/src/ldo.c b/src/ldo.c index d1bf786..30333bf 100644 --- a/src/ldo.c +++ b/src/ldo.c @@ -274,7 +274,7 @@ int luaD_precall (lua_State *L, StkId func, int nresults) { CallInfo *ci; StkId st, base; Proto *p = cl->p; - luaD_checkstack(L, p->maxstacksize); + luaD_checkstack(L, p->maxstacksize + p->numparams); func = restorestack(L, funcr); base = func + 1; >
Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
AgeCommit message (Expand)Author
2020-03-22gnu: Add python-privy....Efraim Flashner
2020-03-22gnu: Add python-argon2-cffi....Efraim Flashner
2020-03-22gnu: Add python-keyrings.alt....Efraim Flashner
2020-03-21gnu: python-scrypt: Use HTTPS home page....Tobias Geerinckx-Rice
2020-03-15gnu: Add python-blurhash....Efraim Flashner
2020-02-24Merge branch 'master' into stagingMarius Bakke
2020-02-21gnu: python-pycrypto: Update home page....Tobias Geerinckx-Rice
2020-02-14gnu: python-pyopenssl: Fix test failure....Marius Bakke
2020-01-11gnu: python-keyring: Update to 21.0.0....Efraim Flashner
2020-01-11gnu: Add python-secretstorage....Efraim Flashner
2020-01-11gnu: Add python-jeepney....Efraim Flashner
2020-01-06gnu: python-axolotl: Don't use unstable tarball....Efraim Flashner
2019-12-18gnu: python-ecdsa: Actually run the test suite....Efraim Flashner
2019-12-18gnu: python-ecdsa: Update to 0.14.1....Efraim Flashner