--- a/src/server_x11.c 2016-08-01 11:58:54.714647794 +0200 +++ b/src/server_x11.c 2016-08-01 11:58:46.606563478 +0200 @@ -151,7 +151,7 @@ DEFINE_COMMAND(open_forwarded_x11) #define X11_MIN_DISPLAY 10 #define X11_MAX_DISPLAY 1000 -/* FIXME: Create the /tmp/.X11-unix directory, if needed. Figure out +/* FIXME: Figure out * if and how we should use /tmp/.X17-lock. Consider using display * "unix:17" instead of just ":17". */ @@ -253,6 +253,7 @@ open_x11_socket(struct ssh_channel *chan old_umask = umask(0077); + mkdir(X11_SOCKET_DIR, S_IRWXU | S_IRWXG | S_IRWXO | S_ISVTX); old_cd = lsh_pushd(X11_SOCKET_DIR, &dir, 0, 0); if (old_cd < 0) { /> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/tests/read-print.scm
AgeCommit message (Expand)Author
2023-03-16read-print: 'read-with-comments' reads comments within gexps.Ludovic Courtès
2023-03-07read-print: Correctly handle comments that follow a list head.Ludovic Courtès
2023-01-09read-print: Do not use extended notation when printing '1+', '1-', etc.Ludovic Courtès
2022-09-20read-print: Correctly support multiple same-named newline forms.Ludovic Courtès
2022-09-02read-print: Define forms for which \n, \t, etc. are not escaped.Ludovic Courtès
2022-09-01read-print: Guess the base to use for integers being printed.Ludovic Courtès
2022-08-10read-print: Report missing closing parens instead of looping.Ludovic Courtès
2022-08-08read-print: Add 'case' and 'cond' special forms.Ludovic Courtès
2022-08-08read-print: Support printing multi-line comments.Ludovic Courtès
2022-08-08read-print: 'canonicalize-comment' leaves top-level comments unchanged.Ludovic Courtès
2022-08-08read-print: Add code to read and write sequences of expressions/blanks.Ludovic Courtès
2022-08-08read-print: Recognize page breaks.Ludovic Courtès
2022-08-08read-print: Read and render vertical space.Ludovic Courtès
2022-08-08style: Move reader and printer to (guix read-print).Ludovic Courtès