--- a/src/server_x11.c 2016-08-01 11:58:54.714647794 +0200
+++ b/src/server_x11.c 2016-08-01 11:58:46.606563478 +0200
@@ -151,7 +151,7 @@ DEFINE_COMMAND(open_forwarded_x11)
#define X11_MIN_DISPLAY 10
#define X11_MAX_DISPLAY 1000
-/* FIXME: Create the /tmp/.X11-unix directory, if needed. Figure out
+/* FIXME: Figure out
* if and how we should use /tmp/.X17-lock. Consider using display
* "unix:17" instead of just ":17".
*/
@@ -253,6 +253,7 @@ open_x11_socket(struct ssh_channel *chan
old_umask = umask(0077);
+ mkdir(X11_SOCKET_DIR, S_IRWXU | S_IRWXG | S_IRWXO | S_ISVTX);
old_cd = lsh_pushd(X11_SOCKET_DIR, &dir, 0, 0);
if (old_cd < 0)
{
/>
koszko
koszko-scripts
Wojtek's customized Guix
Age Commit message (Expand ) Author
2020-10-27 gnu: acl: Fix cross-compilation. ...This is a follow-up of 6693eac6eb9e13852f2b4156f1e9ebcd70ec43b6.
* gnu/packages/acl.scm (acl): Disable tests when cross-compiling.
Mathieu Othacehe
2020-10-10 gnu: acl: Disable tests for the Hurd. ...* gnu/packages/acl.scm (acl)[arguments]: Set #:tests? to #f when building for
the Hurd.
Jan (janneke) Nieuwenhuizen
2020-01-14 gnu: acl: Do not build the static library. ...* gnu/packages/acl.scm (acl)[arguments]: Add #:configure-flags.
Marius Bakke
2019-03-01 gnu: acl: Update to 2.2.53. ...* gnu/packages/patches/acl-hurd-path-max.patch,
gnu/packages/patches/acl-fix-perl-regex.patch: Delete files.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/acl.scm (acl): Update to 2.2.53.
[source](uri): Adjust for renamed tarball.
[arguments]: Remove #:test-target. Adjust disabled tests. Don't override
install phase.
Marius Bakke
2018-03-16 gnu: acl: Use invoke instead of system*. ...* gnu/packages/acl.scm (acl)[arguments]: Use invoke. All phases return #t.
Mark H Weaver
2018-03-15 gnu: acl: Fix build failure. ...* gnu/packages/acl.scm (acl)[arguments]: Add phase
"ensure-no-mtimes-pre-1980".
Ricardo Wurmus