From 38386bd482c0a8102a79958cb3eddcb97a167ca3 Mon Sep 17 00:00:00 2001 From: Con Kolivas Date: Fri, 9 Mar 2018 17:39:40 +1100 Subject: [PATCH] CVE-2017-8842 Fix divide-by-zero in bufRead::get --- libzpaq/libzpaq.h | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/libzpaq/libzpaq.h b/libzpaq/libzpaq.h index 93387da..cbe211d 100644 --- a/libzpaq/libzpaq.h +++ b/libzpaq/libzpaq.h @@ -465,7 +465,8 @@ struct bufRead: public libzpaq::Reader { int get() { if (progress && !(*s_len % 128)) { - int pct = (total_len - *s_len) * 100 / total_len; + int pct = (total_len > 0) ? + (total_len - *s_len) * 100 / total_len : 100; if (pct / 10 != *last_pct / 10) { int i; '/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/doc/htmlxref.cnf
AgeCommit message (Collapse)Author
2020-01-12doc: Update htmlxref.cnf.Ludovic Courtès
* doc/htmlxref.cnf: Update from Texinfo. Add entries for "mes", "guix.ru", and "guix.zh_CN".
2019-05-04doc: Update htmlxref.cnf.Ludovic Courtès
* doc/htmlxref.cnf (G): Switch to https. (geiser, guix.de, guix.es, hurd): New entries.
2018-07-05doc: Update URL of the Emacs-Guix manual.Ludovic Courtès
* doc/htmlxref.cnf (EMACS_GUIX): Update URL.
2018-07-05doc: Mention translations of the manual.Ludovic Courtès
* doc/guix.texi (Top): Add note about l10n. * doc/htmlxref.cnf: Add "guix.fr".
2017-05-30doc: htmlxref: Fix link to Emacs-Guix manual.Alex Kost
Reported-by: Ludovic Courtès <ludo@gnu.org> This fixes a regression introduced by commit 8ca0c88a894c685b624757e38ee7663534f03460. * doc/htmlxref.cnf (EMACS_GUIX): Fix the link to 'html_node'.
2017-05-04doc: Add references to Emacs-Guix manual.Alex Kost
* doc/htmlxref.cnf: Add links to the real manual. * doc/contributing.texi (Formatting Code): Add reference to it. * doc/guix.texi (Package Management): Likewise.