From 38386bd482c0a8102a79958cb3eddcb97a167ca3 Mon Sep 17 00:00:00 2001 From: Con Kolivas Date: Fri, 9 Mar 2018 17:39:40 +1100 Subject: [PATCH] CVE-2017-8842 Fix divide-by-zero in bufRead::get --- libzpaq/libzpaq.h | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/libzpaq/libzpaq.h b/libzpaq/libzpaq.h index 93387da..cbe211d 100644 --- a/libzpaq/libzpaq.h +++ b/libzpaq/libzpaq.h @@ -465,7 +465,8 @@ struct bufRead: public libzpaq::Reader { int get() { if (progress && !(*s_len % 128)) { - int pct = (total_len - *s_len) * 100 / total_len; + int pct = (total_len > 0) ? + (total_len - *s_len) * 100 / total_len : 100; if (pct / 10 != *last_pct / 10) { int i; ='selected'>koszko Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/nix
AgeCommit message (Expand)Author
2022-06-05daemon: Quote consistently within a string....Tobias Geerinckx-Rice
2022-05-29daemon: Clarify ‘--check’ error when outputs are missing....Tobias Geerinckx-Rice
2022-05-18daemon: runChild() is forbidden to talk during environment set up...yarl-baudig@mailoo.org
2022-04-14daemon: Support systemd-style socket activation....Ludovic Courtès
2022-01-18daemon: Always default to gzip for log compression....Ludovic Courtès
2021-11-27daemon: Print the line whence we expect an integer....Tobias Geerinckx-Rice
2021-11-25daemon: Read substitute nar size as 'unsigned long long'....Ludovic Courtès
2021-11-25daemon: Read unsigned nar size and download size from substituter....Ludovic Courtès
2021-11-19daemon: Micro-optimize 'deletePath'....Ludovic Courtès
2021-11-16daemon: Do not deduplicate files smaller than 8 KiB....Ludovic Courtès
2021-10-01build: Don’t delete ‘guix-gc.timer’ file....Xinglu Chen
2021-09-20etc: Add systemd files for running ‘guix gc’ periodically...Thiago Jung Bauermann
2021-04-09daemon: 'guix substitute' replies on FD 4....Ludovic Courtès
2021-04-03daemon: Remove dead code....Ludovic Courtès
2021-03-30gnu: guix: Fix openrc init scripts....zimoun
2021-03-18daemon: Prevent privilege escalation with '--keep-failed' [security]....Ludovic Courtès
2021-03-17daemon: Correctly handle '--discover' with no value....Ludovic Courtès