Build Lirc reproducibly. https://sourceforge.net/p/lirc/tickets/301/ https://sourceforge.net/p/lirc/git/merge-requests/33/ https://sourceforge.net/p/lirc/git/merge-requests/34/ https://sourceforge.net/p/lirc/git/merge-requests/36/ diff -Naur lirc-0.10.2a/python-pkg/lirc/database.py lirc-0.10.2/python-pkg/lirc/database.py --- lirc-0.10.2a/python-pkg/lirc/database.py 1970-01-01 01:00:01.000000000 +0100 +++ lirc-0.10.2/python-pkg/lirc/database.py 2023-01-20 14:23:29.414088668 +0100 @@ -160,7 +160,7 @@ d['device_hint'] = hint configs = {} - for path in glob.glob(configdir + '/*.conf'): + for path in sorted(glob.glob(configdir + '/*.conf')): with open(path) as f: cf = yaml.load(f.read(), Loader = Loader) configs[cf['config']['id']] = cf['config'] diff -Naur lirc-0.10.2a/tools/lirc-lsplugins.cpp lirc-0.10.2/tools/lirc-lsplugins.cpp --- lirc-0.10.2a/tools/lirc-lsplugins.cpp 1970-01-01 01:00:01.000000000 +0100 +++ lirc-0.10.2/tools/lirc-lsplugins.cpp 2023-01-20 14:24:42.719085612 +0100 @@ -413,10 +413,9 @@ static void print_yaml_header(void) { static const char* const YAML_HEADER = - "#\n# Generated by lirc-lsplugins --yaml (%s) at %s#\n "; - const time_t now = time(NULL); + "#\n# Generated by lirc-lsplugins --yaml (%s)#\n "; - printf(YAML_HEADER, VERSION, ctime(&now)); + printf(YAML_HEADER, VERSION); printf("\ndrivers:\n"); } services/dict.scm?id=8a3b574b9c7ae6806247aefb22e6597c0ea4a8b7'>diff
path: root/gnu/services/dict.scm
AgeCommit message (Expand)Author
2023-06-24services: dicod: Use one inetd endpoint per interface....Ludovic Courtès
2023-05-21services: Transient inetd services inherit requirements....Ludovic Courtès
2023-05-11services: dicod, bitlbee: Pass 'make-inetd-constructor' a list of endpoints....Ludovic Courtès
2023-03-17services: dict: Deprecate 'dicod-service' procedure....Bruno Victal
2022-11-18services: Add Shepherd 'configuration' action to various services....Ludovic Courtès
2022-05-02services: Make sure Shepherd destructors match constructors....Ludovic Courtès
2022-05-01services: dicod: Use 'make-inetd-constructor'....Ludovic Courtès
2022-05-01services: dicod: Rewrite using 'least-authority-wrapper'....Ludovic Courtès