Build Lirc reproducibly.
https://sourceforge.net/p/lirc/tickets/301/
https://sourceforge.net/p/lirc/git/merge-requests/33/
https://sourceforge.net/p/lirc/git/merge-requests/34/
https://sourceforge.net/p/lirc/git/merge-requests/36/
diff -Naur lirc-0.10.2a/python-pkg/lirc/database.py lirc-0.10.2/python-pkg/lirc/database.py
--- lirc-0.10.2a/python-pkg/lirc/database.py 1970-01-01 01:00:01.000000000 +0100
+++ lirc-0.10.2/python-pkg/lirc/database.py 2023-01-20 14:23:29.414088668 +0100
@@ -160,7 +160,7 @@
d['device_hint'] = hint
configs = {}
- for path in glob.glob(configdir + '/*.conf'):
+ for path in sorted(glob.glob(configdir + '/*.conf')):
with open(path) as f:
cf = yaml.load(f.read(), Loader = Loader)
configs[cf['config']['id']] = cf['config']
diff -Naur lirc-0.10.2a/tools/lirc-lsplugins.cpp lirc-0.10.2/tools/lirc-lsplugins.cpp
--- lirc-0.10.2a/tools/lirc-lsplugins.cpp 1970-01-01 01:00:01.000000000 +0100
+++ lirc-0.10.2/tools/lirc-lsplugins.cpp 2023-01-20 14:24:42.719085612 +0100
@@ -413,10 +413,9 @@
static void print_yaml_header(void)
{
static const char* const YAML_HEADER =
- "#\n# Generated by lirc-lsplugins --yaml (%s) at %s#\n ";
- const time_t now = time(NULL);
+ "#\n# Generated by lirc-lsplugins --yaml (%s)#\n ";
- printf(YAML_HEADER, VERSION, ctime(&now));
+ printf(YAML_HEADER, VERSION);
printf("\ndrivers:\n");
}
id=0e680920b9e54d7c8a901b1c9cf02ce4468f44ed'>diff
|
Age | Commit message (Expand) | Author |
2020-03-16 | tests: opensmtpd: Check /var/spool/mail instead of /var/mail....The test had been failing since the upgrade to 6.6.3p1 in commit
2dbfd8eec43b602d23cee3fdd2842cc333e36c24.
* gnu/services/mail.scm (opensmtpd-activation): Create /var/spool/mail.
* gnu/tests/mail.scm (run-opensmtpd-test): Check /var/spool/mail instead
of /var/mail.
| Ludovic Courtès |
2020-03-16 | tests: opensmtpd: Gracefully handle test failure....Previously the 'wait' loop would run for ~1024 seconds, at which point
we'd reach the file descriptor limit due to the leak in 'queue-empty?'.
* gnu/tests/mail.scm (run-opensmtpd-test)[test]("mail arrived"): In
'queue-empty?', close PIPE to avoid file descriptor leak. In 'wait'
loop, arrange to run at most 20 times.
| Ludovic Courtès |
2020-03-09 | tests: getmail: Provide a pre-initialized user account password....* gnu/tests/mail.scm (%getmail-os): Rewrite so that the "alice" account
has a password.
(run-getmail-test)[test]("set password for alice"): Remove. This would
not work since commit 8b9cad01e9619f53dc5a65892ca6a09ca5de3447 since
'passwd' would no longer be in $PATH.
| Ludovic Courtès |
2020-01-31 | gnu: Update opensmtpd configuration grammar....This follows up on commit 0d486909083c98d7c75cdfc027f89e69f9bf8f48.
* gnu/services/mail.scm (%default-opensmtpd-config-file): Adapt to ‘new’
≥6.4 grammar.
* gnu/tests/mail.scm (%opensmtpd-os): Likewise.
| Tobias Geerinckx-Rice |
2020-01-20 | tests: mail: Remove %getmail-os from the bottom of the file....This was left over when debugging the system test.
* gnu/tests/mail.scm: Remove %getmail-os from the bottom of the file.
| Christopher Baines |